Bug 1483547 - overcloud nova list empty and dashboard not work.
Summary: overcloud nova list empty and dashboard not work.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 11.0 (Ocata)
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Eoghan Glynn
QA Contact: Joe H. Rahme
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-21 11:36 UTC by RegisJ
Modified: 2019-09-09 17:00 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-25 19:40:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description RegisJ 2017-08-21 11:36:51 UTC
Description of problem:

After a successful stack overcloud deployement using methode Configuring a Basic Overcloud with the CLI Tools (chapter 5) dashboard was not accessible and nova list (after sourcing overcloudrc) is empty. 3 Computes and 1 Control.


Version-Release number of selected component (if applicable):

OpenStack 11.

How reproducible:

Yes more than 4 time we delete and re-deploy our overcloud with still the same issue


Steps to Reproduce:
1. Following installation guiide.


Actual results:

with user stack

[stack@OpenStack-Undercloud ~]$ source stackrc
[stack@OpenStack-Undercloud ~]$ nova list
+--------------------------------------+------------------------+--------+------------+-------------+--------------------------+
| ID                                   | Name                   | Status | Task State | Power State | Networks                 |
+--------------------------------------+------------------------+--------+------------+-------------+--------------------------+
| 8b768286-6c9e-4004-aa4c-ac6b687e9539 | overcloud-compute-0    | ACTIVE | -          | Running     | ctlplane=135.120.182.191 |
| 991368cf-edc0-4b8c-97ed-df654d03dced | overcloud-compute-1    | ACTIVE | -          | Running     | ctlplane=135.120.182.196 |
| f1c0fd82-b57a-43b3-a70d-73e10fe31964 | overcloud-compute-2    | ACTIVE | -          | Running     | ctlplane=135.120.182.197 |
| f4065796-9fc2-46ca-9208-2bf2caac2a21 | overcloud-controller-0 | ACTIVE | -          | Running     | ctlplane=135.120.182.195 |
+--------------------------------------+------------------------+--------+------------+-------------+--------------------------+

it's ok.

[stack@OpenStack-Undercloud ~]$ source overcloudrc
[stack@OpenStack-Undercloud ~]$ nova list
+----+------+--------+------------+-------------+----------+
| ID | Name | Status | Task State | Power State | Networks |
+----+------+--------+------------+-------------+----------+
+----+------+--------+------------+-------------+----------+

???

Dashboard note accessible too.

Login to control and compute host is ok.

Expected results:


Additional info:

Comment 1 RegisJ 2017-08-21 11:39:15 UTC
For Dashboard:

has result of entering URL : http://135.120.182.194:5000/v2.0

I have this windows ...

{"version": {"status": "deprecated", "updated": "2016-08-04T00:00:00Z", "media-types": [{"base": "application/json", "type": "application/vnd.openstack.identity-v2.0+json"}], "id": "v2.0", "links": [{"href": "http://135.120.182.194:5000/v2.0/", "rel": "self"}, {"href": "https://docs.openstack.org/", "type": "text/html", "rel": "describedby"}]}}

Comment 3 melanie witt 2017-08-25 15:09:52 UTC
Tthe result of 'nova list' immediately after installing the overcloud is expected to be an empty list because you have not yet created any VMs. You would have to create a VM before you see it in 'nova list".

For the dashboard, you are using the wrong URL. The URL "http://135.120.182.194:5000/v2.0" is the Keystone authentication URL.

To access the dashboard, you need to visit the hostname where the dashboard has been installed [1]: "http://HOSTNAME/dashboard/"

Can you try that and let me know if it works for you?

[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/html/introduction_to_the_openstack_dashboard/the_openstack_dashboard

Comment 4 RegisJ 2017-08-25 15:17:13 UTC
Hello, for the nova list empty it's ok sorry.

For dashboard I have also made the trial and that's not work

we failed in time out 504 Gateway Time-out
The server didn't respond in time.

The strange thing and we have installed in june for a first try of oepnstack 11 and dashbord work correctly.

We have upgraded our configuration to have 8 Node on a C7000 HP system and re-installing openstack from scrath from the latest version available.

And we failed in this issue.

Now our configuration is the following :
[stack@Undercloud ~]$ nova list
+--------------------------------------+------------------------+--------+------------+-------------+------------------------+
| ID                                   | Name                   | Status | Task State | Power State | Networks               |
+--------------------------------------+------------------------+--------+------------+-------------+------------------------+
| 664575bb-518c-41ca-aea7-5c6021d7344e | overcloud-compute-0    | ACTIVE | -          | Running     | ctlplane=135.117.39.56 |
| 53e40bcb-c823-4f44-8fd8-83fe595a5048 | overcloud-compute-1    | ACTIVE | -          | Running     | ctlplane=135.117.39.60 |
| 1f9c2aed-bcd2-4202-a82f-22633c2b19a0 | overcloud-compute-2    | ACTIVE | -          | Running     | ctlplane=135.117.39.62 |
| 21993e2d-a731-46c9-a80b-9cc71c58106f | overcloud-compute-3    | ACTIVE | -          | Running     | ctlplane=135.117.39.67 |
| 92af1bbf-f9b8-41e3-bf8e-9ae4795d3cd8 | overcloud-compute-4    | ACTIVE | -          | Running     | ctlplane=135.117.39.65 |
| d9abf4e5-0391-4f55-a189-51ba9ad28761 | overcloud-compute-5    | ACTIVE | -          | Running     | ctlplane=135.117.39.51 |
| a311d886-c690-4c21-81c9-3f5f5d1f4fb0 | overcloud-compute-6    | ACTIVE | -          | Running     | ctlplane=135.117.39.53 |
| facb7442-6b8b-41e2-a1a8-2f5ac7b89c18 | overcloud-controller-0 | ACTIVE | -          | Running     | ctlplane=135.117.39.55 |
+--------------------------------------+------------------------+--------+------------+-------------+------------------------+

We have anotheer openstack currently under trial and dashboard work correctly...

Comment 5 melanie witt 2017-08-25 15:42:32 UTC
Okay, so for the dashboard, it looks like you're hitting one of the issues that Martin mentioned in comment 2, particularly: https://access.redhat.com/solutions/3146571

Could you try that solution and let me know if it works? Thanks.

Comment 6 RegisJ 2017-08-25 19:31:18 UTC
YES !!!! Thank you very much. That's fix my issue !!!

Adding this in /etc/httpd/conf.d/10-horizon_vhost.conf 

WSGIApplicationGroup %{GLOBAL}

work !

You can close this issue.

Thank you again.

BR

RJ.

Comment 7 melanie witt 2017-08-25 19:40:42 UTC
Great, thanks for verifying!

Closing this as NOTABUG since the dashboard issue is already currently documented.


Note You need to log in before you can comment on or make changes to this bug.