Bug 14836 - xinetd fails on restart if "bind" directive used
Summary: xinetd fails on restart if "bind" directive used
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xinetd   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-29 08:58 UTC by Reuben Farrelly
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-29 08:58:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Reuben Farrelly 2000-07-29 08:58:43 UTC
I am currently running xinetd-2.1.8.9pre8-11 and have noticed a problem if 
I restart xinetd after having used the "bind" directive in a startup file 
as shown below:

bind                    = 203.42.190.225

xinetd does not seem to like being stopped and started so quickly, and 
this message appears in the log:

Jul 29 16:01:52 tornado xinetd[7563]: bind failed (Address already in use 
(errno = 98)). service = imap

The service then fails to listen on the nominated port (in this case 143).

I've worked around the problem by stopping xinetd and starting it a few 
seconds later.

Maybe some sort of sleep statement in the /etc/rc.d/init/xinetd script 
would also fix this?

Comment 1 Trond Eivind Glomsrxd 2000-07-29 17:58:17 UTC
The current package uses runs with the "-reuse" flag, which should solve the
problem

Comment 2 Reuben Farrelly 2000-07-31 14:26:36 UTC
You are of course correct that this is the way the latest xinetd is configured, 
however the problem persists despite that, and I still need to manually shut 
down and restart xinetd in order to solve the problems with interface binding 
as I originally described...

Comment 3 Trond Eivind Glomsrxd 2000-07-31 14:58:37 UTC
I can't reproduce this - please try beta5, and reopen if still a problem.


Note You need to log in before you can comment on or make changes to this bug.