Bug 1483854 - systemd breaks dnf ugprade in containers
Summary: systemd breaks dnf ugprade in containers
Keywords:
Status: CLOSED DUPLICATE of bug 1483553
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-22 07:01 UTC by Standa Laznicka
Modified: 2017-09-18 12:14 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-18 12:14:23 UTC
Type: Bug


Attachments (Terms of Use)
dnf upgrade log (100.76 KB, text/plain)
2017-08-22 07:13 UTC, Standa Laznicka
no flags Details

Description Standa Laznicka 2017-08-22 07:01:13 UTC
Description of problem:
When dnf upgrade is run in a container, it fails when running systemd rpm scriptlet.

Version-Release number of selected component (if applicable):
systemd-234-5.fc27.x86_64

How reproducible:
Always

Steps to Reproduce:
1. # docker run -ti --rm registry.fedoraproject.org/fedora:rawhide
2. # sudo dnf upgrade -y --nogpgcheck

Actual results:
"""
Running scriptlet: systemd-234-5.fc27.x86_64                            351/351 
Failed to connect to bus: No such file or directory
BDB1539 Build signature doesn't match environment
failed loading RPMDB
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
"""

Expected results:
Successful upgrade.

Additional information:
This seems to be the same issue as https://bugzilla.redhat.com/show_bug.cgi?id=1411299. On F27 it blocks building freeipa-docker container.

Comment 1 Standa Laznicka 2017-08-22 07:13:04 UTC
Created attachment 1316542 [details]
dnf upgrade log

Comment 2 Lukas Slebodnik 2017-09-15 08:24:20 UTC
I assume it is a duplicate of 
https://bugzilla.redhat.com/show_bug.cgi?id=1483553

Comment 3 Standa Laznicka 2017-09-18 12:14:23 UTC
Most probably.

*** This bug has been marked as a duplicate of bug 1483553 ***


Note You need to log in before you can comment on or make changes to this bug.