Bug 1483883 - [free-int][free-stg][starter-ca-central-1][online-int] Web login hits error in browser private window
Summary: [free-int][free-stg][starter-ca-central-1][online-int] Web login hits error i...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-22 08:21 UTC by Xingxing Xia
Modified: 2020-05-01 18:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-01 18:36:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
Web_login_in_private_window_hits_error (50.77 KB, image/png)
2017-08-22 08:21 UTC, Xingxing Xia
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1537120 unspecified CLOSED Invalid request Client state could not be verified 2020-10-14 00:28:05 UTC

Internal Links: 1537120

Description Xingxing Xia 2017-08-22 08:21:22 UTC
Created attachment 1316556 [details]
Web_login_in_private_window_hits_error

Description of problem:
Web login hits error in browser private window (Firefox reproduces, Chrome does not)
OCP 3.6 does not reproduce this.

As in bug title, tried the clusters [free-int][free-stg][starter-ca-central-1][online-int], they all reproduce.
Tried in online-stg, it does not reproduce

Currently [free-int][free-stg][starter-ca-central-1][online-int] are all 3.6, while online-stg is still v3.5.
So seems it is only Online v3.6 issue.

Version-Release number of selected component (if applicable):
OCP v3.6.173.0.5

How reproducible:
Always


Steps to Reproduce:
1. In Firefox, click upper right menu, click "New Private Window"
2. In the private window, access Online web console, input u/p, click to login
3. Click the "console" link in the error messages

Actual results:
2. Page returns following error messages:

Error
Invalid request
Client state could not be verified

Return to the console.

3. Can redirect and later enter web console without again u/p

Expected results:
2. Should login without error messages

Additional info:

Comment 1 Jordan Liggitt 2017-08-22 15:09:00 UTC
I can only recreate this about one in every five login attempts. Tracing shows the client state passed successfully through the oauth flow, and localStorage preserved correctly in the console.

With debugging breakpoints in place, I cannot recreate this at all.

Comment 2 Xingxing Xia 2018-02-06 10:16:48 UTC
This seems can be easily reproduced now (today I tried free-int and conclude this), could you related guys try again to see if you can reproduce?

Comment 3 Yadan Pei 2018-02-07 02:25:04 UTC
Sometimes I could reproduce the issue, but I'm not sure the correct reproduce steps, I only try randomly

Comment 4 Yadan Pei 2018-02-07 02:26:01 UTC
We may need to figure out a more stable reproduce steps so that we could narrow down the problem

Comment 5 Samuel Padgett 2018-02-07 14:35:31 UTC
(In reply to Xingxing Xia from comment #2)
> This seems can be easily reproduced now (today I tried free-int and conclude
> this), could you related guys try again to see if you can reproduce?

Not for me. I could only reproduce once in many attempts and unfortunately I was not able to set a breakpoint.

Marking this low again since it is infrequent and only appears to affect Firefox in private browsing mode.

Note that there is a related issue that isn't specific to private browsing: https://bugzilla.redhat.com/show_bug.cgi?id=1488394

Comment 6 Samuel Padgett 2020-05-01 18:36:36 UTC
Closing as 3.6 is no longer supported. If this is still happening with current versions, please open a new bug with updated details.


Note You need to log in before you can comment on or make changes to this bug.