Bug 1484008 (CVE-2017-11185) - CVE-2017-11185 strongswan: Insufficient Input Validation in gmp Plugin
Summary: CVE-2017-11185 strongswan: Insufficient Input Validation in gmp Plugin
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2017-11185
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1484009 1484010
Blocks: 1484011
TreeView+ depends on / blocked
 
Reported: 2017-08-22 13:02 UTC by Adam Mariš
Modified: 2021-02-17 01:42 UTC (History)
3 users (show)

Fixed In Version: strongswan 5.6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-23 04:21:12 UTC


Attachments (Terms of Use)

Description Adam Mariš 2017-08-22 13:02:53 UTC
The gmp plugin in strongSwan before 5.6.0 allows remote attackers to
cause a denial of service (NULL pointer dereference and daemon crash)
via a crafted RSA signature.

Upstream patch:

https://download.strongswan.org/security/CVE-2017-11185/strongswan-4.4.0-5.5.3_gmp_mpz_export.patch

External References:

https://www.strongswan.org/blog/2017/08/14/strongswan-vulnerability-(cve-2017-11185).html

Comment 1 Adam Mariš 2017-08-22 13:03:16 UTC
Created strongswan tracking bugs for this issue:

Affects: epel-all [bug 1484010]
Affects: fedora-all [bug 1484009]

Comment 2 Huzaifa S. Sidhpurwala 2017-08-23 04:21:12 UTC
Statement:

The version of strongimcv package shipped with Red Hat Enterprise Linux 7, does not enable the gmp plugin and therefore is not affected by this flaw.


Note You need to log in before you can comment on or make changes to this bug.