Bug 1484015 - [kernel] bad page state in process CPU 0/KVM crashes virtual guest session
Summary: [kernel] bad page state in process CPU 0/KVM crashes virtual guest session
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-22 13:13 UTC by Joachim Frieben
Modified: 2018-03-05 13:51 UTC (History)
8 users (show)

Fixed In Version: kernel-4.15.6-300.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-05 13:51:44 UTC
Type: Bug


Attachments (Terms of Use)
Crash-related output of 'dmesg'. (3.93 KB, text/plain)
2017-08-22 13:13 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2017-08-22 13:13:19 UTC
Created attachment 1316645 [details]
Crash-related output of 'dmesg'.

Description of problem:
When running Fedora 26 in gnome-boxes, the virtual guest exhibits frequent crashes due to a bad page state in the host kernel (see backtrace).

Version-Release number of selected component (if applicable):
kernel-4.13.0-0.rc6.git0.1.fc27

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora 26 virtual guest in gnome-boxes.
2. Run firefox.

Actual results:
After using firefox for a short amount of time, the GNOME session crashes and the user is thrown back to the graphical login manager.

Expected results:
Firefox runs without issue.

Additional info:
- After installing kernel-4.12.8-300.fc26 on the Fedora 27 host and rebooting the system, the virtual guest works without any issue.
- The issue cannot be reported by the problem reporting tool because: "The backtrace does not contain enough meaningful function frames to be reported. It is annoying but it does not necessary signalize a problem with your computer. ABRT will not allow you to create a report in a bug tracking system but you can contact kernel maintainers via e-mail.".

Comment 1 Laura Abbott 2018-02-20 19:53:01 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  As kernel maintainers, we try to keep up with bugzilla but due the rate at which the upstream kernel project moves, bugs may be fixed without any indication to us. Due to this, we are doing a mass bug update across all of the Fedora 27 kernel bugs.
 
Fedora 27 has now been rebased to 4.15.3-300.f27.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you experience different issues, please open a new bug report for those.


Note You need to log in before you can comment on or make changes to this bug.