Bug 1484073 - Inconsistent value in dmidecode on aarch64 vs. x86_64
Summary: Inconsistent value in dmidecode on aarch64 vs. x86_64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.4-Alt
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Wei Huang
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1173755
TreeView+ depends on / blocked
 
Reported: 2017-08-22 15:40 UTC by Lukas Doktor
Modified: 2018-11-01 11:01 UTC (History)
13 users (show)

Fixed In Version: qemu-kvm-rhev-2.12.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-01 11:01:10 UTC
Target Upstream Version:
tlavigne: needinfo? (jcm)
wehuang: needinfo+


Attachments (Terms of Use)

Description Lukas Doktor 2017-08-22 15:40:41 UTC
Description of problem:

The `dmidecode -t 1` on x86_64 includes the machine type, but on arm it only says "1.0".

Version-Release number of selected component (if applicable):
qemu-kvm-2.9.0-21.el7a.aarch64

How reproducible:
Always

Steps to Reproduce:
1. run guest with "-machine virt"
2. in the guest run "dmidecode -t 1"

Actual results:
avocado.test: [stdout] # dmidecode 3.0
avocado.test: [stdout] Getting SMBIOS data from sysfs.
avocado.test: [stdout] SMBIOS 3.0.0 present.
avocado.test: [stdout] 
avocado.test: [stdout] Handle 0x0100, DMI type 1, 27 bytes
avocado.test: [stdout] System Information
avocado.test: [stdout]  Manufacturer: QEMU
avocado.test: [stdout]  Product Name: KVM Virtual Machine
avocado.test: [stdout]  Version: 1.0
avocado.test: [stdout]  Serial Number: Not Specified
avocado.test: [stdout]  UUID: Not Settable
avocado.test: [stdout]  Wake-up Type: Power Switch
avocado.test: [stdout]  SKU Number: Not Specified
avocado.test: [stdout]  Family: Red Hat Enterprise Linux

Expected results:
avocado.test: [stdout] # dmidecode 3.0
avocado.test: [stdout] Getting SMBIOS data from sysfs.
avocado.test: [stdout] SMBIOS 3.0.0 present.
avocado.test: [stdout] 
avocado.test: [stdout] Handle 0x0100, DMI type 1, 27 bytes
avocado.test: [stdout] System Information
avocado.test: [stdout]  Manufacturer: QEMU
avocado.test: [stdout]  Product Name: KVM Virtual Machine
avocado.test: [stdout]  Version: RHEL 7.4.0 ARM Virtual Machine (default)
avocado.test: [stdout]  Serial Number: Not Specified
avocado.test: [stdout]  UUID: Not Settable
avocado.test: [stdout]  Wake-up Type: Power Switch
avocado.test: [stdout]  SKU Number: Not Specified
avocado.test: [stdout]  Family: Red Hat Enterprise Linux


Additional info:
Basically for "-machine virt" using the same logic as on x86_64 it should output:

    Version: RHEL 7.4.0 ARM Virtual Machine (default)

and with "-machine virt-rhel7.4.0"

    Version: RHEL 7.4.0 ARM Virtual Machine (alias of virt-rhel7.4.0)

This is based on `smbios_table.machine_type` avocado-vt test results.

Comment 2 Andrew Jones 2017-09-26 10:53:53 UTC
Wei sent a patch upstream that changes the useless "1.0" version string to mc->name, like upstream x86 machine types have. That will result in, e.g.

System Information
        Manufacturer: QEMU
        Product Name: KVM Virtual Machine
        Version: virt-2.10
        Serial Number: Not Specified
        UUID: B901BA96-3A85-45EF-9724-03FBA645119D
        Wake-up Type: Power Switch
        SKU Number: Not Specified
        Family: Not Specified

which is correct, so the expected results in comment 0 are not correct, regarding upstream. The expected results aren't correct regarding downstream either, though. Downstream we should have, e.g.

System Information
	Manufacturer: Red Hat
	Product Name: KVM
	Version: RHEL 7.4.0 ARM Virtual Machine
	Serial Number: Not Specified
	UUID: 69198DFF-E2C5-47AB-8071-E657EEF4D779
	Wake-up Type: Power Switch
	SKU Number: Not Specified
	Family: Red Hat Enterprise Linux

We still need a downstream patch to fix that. We can use this BZ for it.

Notice, IMO, that the (default) and (alias of ...) stuff should not be there. If it is there, then we should fix it (upstream and downstream) too.

Comment 10 errata-xmlrpc 2018-11-01 11:01:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443


Note You need to log in before you can comment on or make changes to this bug.