Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1484110 - filesystem corruption if lvchange while raid1 conversion active [NEEDINFO]
Summary: filesystem corruption if lvchange while raid1 conversion active
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.9
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: ---
Assignee: Heinz Mauelshagen
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1508914
TreeView+ depends on / blocked
 
Reported: 2017-08-22 17:27 UTC by Frank Ch. Eigler
Modified: 2018-06-04 21:34 UTC (History)
16 users (show)

Fixed In Version: lvm2-2.02.143-13.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1508914 (view as bug list)
Environment:
Last Closed: 2018-06-04 21:34:54 UTC
Target Upstream Version:
toneata: needinfo-
mcsontos: needinfo? (cluster-qe)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Debian BTS 855895 0 None None None 2017-08-22 17:27:58 UTC

Description Frank Ch. Eigler 2017-08-22 17:27:58 UTC
Essentially the identical bug reported to Debian in spring 2017 affects RHEL6.9, with ext4.  We suffered ext4 filesystem corruption when doing the same steps as in the referenced Debian bug.  Please backport the fix.

Comment 2 Marian Csontos 2017-08-24 11:27:36 UTC
Acked. The patch looks simple enough and harmless even for ZStream:

https://sourceware.org/git/?p=lvm2.git;a=commitdiff;h=8ab072507706fb826eee05eb369429ad0a7a406a

Comment 3 Frank Ch. Eigler 2017-08-24 12:05:27 UTC
> Acked. The patch looks simple enough and harmless even for ZStream:
> https://sourceware.org/git/?p=lvm2.git [...]

Coincidentally, sourceware.org itself was the machine hit by this bug.

Comment 14 Marian Csontos 2018-02-21 12:04:36 UTC
Marcel, could we get this on ACL, please? It must have been missed as it was in MODIFIED since long time ago.

Comment 15 Marian Csontos 2018-02-21 12:12:30 UTC
FYI, it is included in 6.9.z, so it would be a regression to exclude this patch.

The 6.10 package is the same as the 6.9.z, except the version/release.

Comment 16 Jan Kurik 2018-02-22 11:34:00 UTC
As the lvm2 component is not on ACL, there is no need to release the fix in rhel-6.10 because the lvm2 package will be taken from the rhel-6.9.z branch during rhel-6.10 compose.

However if the lvm2 appears on ACL till the rhel-6.10 GA date, the fix for this bug needs to be released in rhel-6.10 as well to avoid regressions.

My proposal here will be to keep this bug open until the rhel-6.10 GA date and then close it as CURRENT_RELEASE. This should be done automatically as part of the rhel-6.10 cleanup after the GA.


Note You need to log in before you can comment on or make changes to this bug.