Bug 1484279 - Keepalived v1.3.5 failing to assign IP for HA interface
Summary: Keepalived v1.3.5 failing to assign IP for HA interface
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z3
: 11.0 (Ocata)
Assignee: anil venkata
QA Contact: Arie Bregman
URL:
Whiteboard:
Depends On:
Blocks: 1484281 1484282 1484283 1485781
TreeView+ depends on / blocked
 
Reported: 2017-08-23 07:49 UTC by Arie Bregman
Modified: 2017-10-31 17:43 UTC (History)
9 users (show)

Fixed In Version: openstack-neutron-10.0.2-9.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1484281 1485781 (view as bug list)
Environment:
Last Closed: 2017-10-31 17:43:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1712388 0 None None None 2017-08-23 07:51:40 UTC
Red Hat Product Errata RHBA-2017:3105 0 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2017-10-31 21:39:54 UTC

Description Arie Bregman 2017-08-23 07:49:25 UTC
Description of problem:

After switching to RHEL 7.4 we see keepalived is unable to read IP address from config file to configure HA interface(though config file is properly configured).

Steps to reproduce:

1. Clone neutron
2. Install Keepalived v1.3.5 and run below functional test
neutron.tests.functional.sanity.test_sanity.SanityTestCaseRoot.test_keepalived_ipv6_support
This test will fail and you can see the errors in syslog.

Syslog failures:

Aug 22 19:52:01 vagrant6 Keepalived[14752]: Starting Keepalived v1.3.5 (03/19,2017), git commit v1.3.5-6-g6fa32f2
Aug 22 19:52:01 vagrant6 Keepalived[14752]: Unable to resolve default script username 'keepalived_script' - ignoring
Aug 22 19:52:01 vagrant6 Keepalived[14752]: Opening file '/tmp/tmpxxwEQH/tmpeVAVKR/router1/keepalived.conf'.
Aug 22 19:52:01 vagrant6 Keepalived[14753]: Starting VRRP child process, pid=14754
Aug 22 19:52:01 vagrant6 Keepalived_vrrp[14754]: Registering Kernel netlink reflector
Aug 22 19:52:01 vagrant6 Keepalived_vrrp[14754]: Registering Kernel netlink command channel
Aug 22 19:52:01 vagrant6 Keepalived_vrrp[14754]: Registering gratuitous ARP shared channel
Aug 22 19:52:01 vagrant6 Keepalived_vrrp[14754]: Opening file '/tmp/tmpxxwEQH/tmpeVAVKR/router1/keepalived.conf'.
Aug 22 19:52:01 vagrant6 Keepalived_vrrp[14754]: (VR_1): Cannot find an IP address to use for interface ha-c896a1c
Aug 22 19:52:02 vagrant6 Keepalived_vrrp[14754]: Stopped
Aug 22 19:52:02 vagrant6 Keepalived[14753]: Keepalived_vrrp exited with permanent error CONFIG. Terminating
Aug 22 19:52:02 vagrant6 Keepalived[14753]: Stopping
Aug 22 19:52:07 vagrant6 Keepalived[14753]: Stopped Keepalived v1.3.5 (03/19,2017), git commit v1.3.5-6-g6fa32f2
Version-Release number of selected component (if applicable):


How reproducible: 100%

Comment 4 anil venkata 2017-10-05 11:55:34 UTC
No doc_text is required as the change was involved in test case only.

Comment 6 errata-xmlrpc 2017-10-31 17:43:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3105


Note You need to log in before you can comment on or make changes to this bug.