Bug 1484399 - [GSS] [OpenJDK] The JVM option ExitOnOutOfMemoryError has been removed when upgrading to 1.7.0_141
Summary: [GSS] [OpenJDK] The JVM option ExitOnOutOfMemoryError has been removed when u...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: java-1.7.0-openjdk
Version: 7.4
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Andrew John Hughes
QA Contact: Lukas Zachar
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-23 12:55 UTC by Francesco Marchioni
Modified: 2018-04-10 17:37 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-10 17:35:37 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
openjdk bug system JDK-8138745 None None None 2017-09-08 17:14 UTC
Icedtea Bugzilla 3465 None None None 2017-10-10 16:46 UTC
Red Hat Product Errata RHBA-2018:0944 None None None 2018-04-10 17:37 UTC

Description Francesco Marchioni 2017-08-23 12:55:04 UTC
Description of problem:
The option ExitOnOutOfMemoryError is no longer available since upgrading from openjdk 1.7.0_131 to 1.7.0_141.
There is no clue from the release notes why this option has been removed.
On the other hand, the option is available in  java-1.8.0-openjdk-devel.x86_64

Version-Release number of selected component (if applicable):
Openjdk 1.7.0_141

How reproducible:
By installing RPM packages as follows:

yum install java-1.7.0-openjdk-devel.x86_64
java -XX:+ExitOnOutOfMemoryError -version
Unrecognized VM option 'ExitOnOutOfMemoryError'

Expected results:
java version "1.7.0_141"

Additional info:

The option works with OpenJDK8:
yum install java-1.8.0-openjdk-devel.x86_64
java -XX:+ExitOnOutOfMemoryError -version
java version "1.8.0_60"

Comment 2 Deepak Bhole 2017-08-23 20:57:42 UTC
Andrew, do you know if this is intentional?

Comment 3 jiri vanek 2017-08-24 14:24:54 UTC
It probably can be returned, but only as  rpm specific patch (==not recommended) as:

$ java -X
    -Xmixed           mixed mode execution (default)
...
    -XshowSettings:locale
                      show all locale related settings and continue

The -X options are non-standard and subject to change without notice.


I tasys it all.... Sorry.

Comment 5 Andrew John Hughes 2017-09-08 17:14:35 UTC
There seems to be some confusion here. I can see no evidence that -XX:+ExitOnOutOfMemoryError has ever been present in java-1.7.0-openjdk.

It was added to OpenJDK 8 in u92:

8138745: Implement ExitOnOutOfMemory and CrashOnOutOfMemory in HotSpot
Reviewed-by: dholmes
Contributed-by: cheleswer.sahu@oracle.com
https://bugs.openjdk.java.net/browse/JDK-8138745

It has never been backported to OpenJDK 7.

The bug confusingly lists it as being in 7u101 and 7u111, but this is a reference to Oracle's proprietary JDK updates (java-1.7.0-oracle)

8138745 is a fairly simple fix, so we could consider backporting it as well. Generally, we've only backported changes going into 8u that have been part of security updates (odd-numbered releases such as 8u91 and 8u141), and not feature updates such as 8u92. I do have an ongoing TODO to look over the Oracle 7u updates for other changes, but it's lower priority than the security updates and ongoing RHEL requests for fixes for both 7 & 8.

Francesco, would it make it easier for you to have this option available in OpenJDK 7?

Comment 7 Andrew John Hughes 2017-10-10 16:46:35 UTC
Scheduled for inclusion in the next upstream release, given its already in the proprietary 7 version and has no effect unless one of the new options is enabled.

Comment 13 errata-xmlrpc 2018-04-10 17:35:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0944


Note You need to log in before you can comment on or make changes to this bug.