Bug 1484405 - Docker upstream repository name length limit
Summary: Docker upstream repository name length limit
Status: CLOSED DUPLICATE of bug 1424689
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories   
(Show other bugs)
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.2
Assignee: Tom McKay
QA Contact: Katello QA List
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-23 13:22 UTC by Tom McKay
Modified: 2018-12-06 20:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-03 15:33:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 18533 None None None 2017-08-23 13:22 UTC
Red Hat Bugzilla 1424689 None None None Never

Internal Trackers: 1424689

Description Tom McKay 2017-08-23 13:22:05 UTC
Trying to add a docker repository with a length of more than 30 characters for the image name part fails with error: "Docker upstream name must be a valid docker name"

This seems somewhat arbitrary, image with a name of more than 30 characters do exist on Docker Hub (and other publicly accessible registries).

<pre>
$ sudo docker search openvswitch | grep -E "/[a-zA-Z0-9-]{30}[^ ]"
docker.io    docker.io/intelonp/centos-source-neutron-openvswitch-agent                            centos-source-neutron-openvswitch-agent         0                    [OK]
docker.io    docker.io/intelonp/centos-source-openvswitch-db-server                                centos-source-openvswitch-db-server             0                    [OK]
docker.io    docker.io/intelonp/centos-source-openvswitch-vswitchd                                 centos-source-openvswitch-vswitchd              0                    [OK]
docker.io    docker.io/rbbratta/centos-source-neutron-openvswitch-agent                            centos-source-neutron-openvswitch-agent         0                    [OK]
docker.io    docker.io/rbbratta/centos-source-openvswitch-db-server                                centos-source-openvswitch-db-server             0                    [OK]
docker.io    docker.io/rbbratta/centos-source-openvswitch-vswitchd                                 centos-source-openvswitch-vswitchd              0                    [OK]
docker.io    docker.io/tripleoupstream/centos-binary-openvswitch-vswitchd                                                                          0

</pre>

Comment 1 Tom McKay 2017-08-23 13:22:09 UTC
Created from redmine issue http://projects.theforeman.org/issues/18533

Comment 2 Tom McKay 2017-08-23 13:22:12 UTC
Upstream bug assigned to tomckay@redhat.com

Comment 6 pm-sat@redhat.com 2017-08-23 14:16:17 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/18533 has been resolved.

Comment 7 Andrii Balakhtar 2017-09-19 14:19:29 UTC
Isn't it a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1424689 ?

Comment 12 jcallaha 2017-11-03 15:33:08 UTC

*** This bug has been marked as a duplicate of bug 1424689 ***

Comment 13 Oleksandr Shtaier 2017-11-07 20:53:51 UTC
Test automation coverage provided in a defect which current BZ duplicated to.


Note You need to log in before you can comment on or make changes to this bug.