Bug 1484430 - After auto-update to RHEL 7.4, initramfs file is missing for new kernel [NEEDINFO]
Summary: After auto-update to RHEL 7.4, initramfs file is missing for new kernel
Keywords:
Status: CLOSED DUPLICATE of bug 1475039
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut
Version: 7.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Release Test Team
URL:
Whiteboard:
: 1490812 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-23 14:51 UTC by Rainer Beyel
Modified: 2018-02-13 15:33 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 16:55:29 UTC
Target Upstream Version:
moddi: needinfo? (lnykryn)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1490812 None None None 2019-11-04 14:16:53 UTC
Red Hat Knowledge Base (Article) 3211181 None None None 2017-10-10 05:48:04 UTC

Internal Links: 1490812

Description Rainer Beyel 2017-08-23 14:51:40 UTC
Description of problem:
The system is managed by Satellite 5.6. with auto errata update "yes". After the auto-update from RHEL 7.3 to RHEL 7.4. initramfs-3.10.0-693.1.1.el7.x86_64.img is missing. Rebooting with the new kernel fails.

Version-Release number of selected component (if applicable):
- RHEL 7.4
- kernel-3.10.0-693.1.1.el7.x86_64
- initramfs-3.10.0-693.1.1.el7.x86_64.img

Steps to Reproduce:
1. System gets updated by Satellite 5.6 (auto errata update)
2. initramfs-3.10.0-693.1.1.el7.x86_64.img is missing
3. reboot to kernel-3.10.0-693.1.1.el7.x86_64 fails

Actual results:
initramfs-3.10.0-693.1.1.el7.x86_64.img is missing and reboot fails

Expected results:
initramfs-3.10.0-693.1.1.el7.x86_64.img gets generated with the installation of kernel-3.10.0-693.1.1.el7.x86_64

Additional info:
A workaround, reported by the customer, is to reinstall the kernel manually. This will create the initramfs file. Also, I executed 'yum update kernel' manually on a RHEL 7.3 testsystem, kernel-3.10.0-693.1.1.el7.x86_64 was installed and initramfs-3.10.0-693.1.1.el7.x86_64.img generated. Maybe this relates to Satellite 5.6?

Comment 3 Andreas Mohr 2017-08-29 05:18:13 UTC
We can confirm this.
Updating kernel rpm via rhnsd/rhn_check
kernel postscript will failed or exit too early?

Aug 29 04:12:26 xxxxx rhnsd[37288]: running program /usr/sbin/rhn_check with PID 37288
Aug 29 04:12:50 xxxxx dracut: dracut-
without further output like
                xxxxx dracut: Executing: /sbin/dracut -f /boot/initramfs-3.10.0-693.1.1.el7.x86_64.img 3.10.0-693.1.1.el7.x86_64

Comment 4 Michal Bocek 2017-08-30 11:42:40 UTC
redhat-upgrade-dracut is used only by redhat-upgrade-tool whose only purpose is to perform upgrades from major version of the system to a new major version, at this time only from RHEL 6 to RHEL 7.

This bug would belong to the redhat-upgrade-dracut component only if you used Red Hat Upgrade Tool to upgrade from RHEL 6 to RHEL 7 and you think this upgrade didn't end up well causing the problems with missing kernel when updating RHEL 7.3 to 7.4. Otherwise I think this bug belongs either to the 'dnf' or 'dracut' component.

Comment 5 Michal Bocek 2017-08-30 11:49:05 UTC
There's no 'dnf' on RHEL 7 but 'yum' instead, of course.

Comment 8 Rainer Beyel 2017-09-08 11:28:01 UTC
Customer reported, that this also *somtimes* happens when manually executing 'yum update' - independent from Satellite 5.6 with auto-update. As before, a reinstall of the kernel solves the issue (creates initramfs...).

Comment 12 Renaud Métrich 2017-10-04 08:40:27 UTC
*** Bug 1490812 has been marked as a duplicate of this bug. ***

Comment 14 Lukáš Nykrýn 2017-10-10 15:29:49 UTC
If a customer has a stable reproducer, can they please add 
debug=yes
to /etc/dracut.conf, try the update and post here output of journalctl?

Comment 16 Lukáš Nykrýn 2017-10-18 14:08:28 UTC
Also can you please check that this is not a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1475039

Comment 25 JB 2017-11-16 19:33:23 UTC
RHEL Support just told me I have this bug.

"Hello,

Now initramfs for latest kernel is present in /boot/grub2/grub.cfg and /boot/. Seems you are hitting a known bug

Bug 1484430 - After auto-update to RHEL 7.4, initramfs file is missing for new kernel
https://bugzilla.redhat.com/show_bug.cgi?id=1484430

I am moving this case to satellite team they can better suggest you for prevention or any other workaround.

We use Satellite 5.6 we are not using upgraded systems. These are RHEL7 the entire time. Also this causes kernel Panics when rebooted.

They are fixed when the kernel is installed. But we also would like to know how to prevent it since we have 200 more servers to patch, and we dont know what is triggering it.

Comment 26 JB 2017-11-16 19:34:48 UTC
(In reply to JB from comment #25)
> RHEL Support just told me I have this bug.
> 
> "Hello,
> 
> Now initramfs for latest kernel is present in /boot/grub2/grub.cfg and
> /boot/. Seems you are hitting a known bug
> 
> Bug 1484430 - After auto-update to RHEL 7.4, initramfs file is missing for
> new kernel
> https://bugzilla.redhat.com/show_bug.cgi?id=1484430
> 
> I am moving this case to satellite team they can better suggest you for
> prevention or any other workaround.
> 
> We use Satellite 5.6 we are not using upgraded systems. These are RHEL7 the
> entire time. Also this causes kernel Panics when rebooted.
> 
> They are fixed when the kernel is installed. But we also would like to know
> how to prevent it since we have 200 more servers to patch, and we dont know
> what is triggering it.

When the kernel is re-installed that is, it is corrected.


Note You need to log in before you can comment on or make changes to this bug.