Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1484523 - 51-hosts at scale fails to complete and does not report an error
Summary: 51-hosts at scale fails to complete and does not report an error
Keywords:
Status: CLOSED DUPLICATE of bug 1484533
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-refresh-config
Version: 10.0 (Newton)
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-23 19:14 UTC by David Vallee Delisle
Modified: 2020-12-14 09:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-29 21:34:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1674732 0 None None None 2017-08-24 13:11:45 UTC

Description David Vallee Delisle 2017-08-23 19:14:09 UTC
Description of problem:
51-hosts fails to complete running, and wedges scale deployments from ever completing. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Have a lot of nodes
2. Add more nodes
3. Again, add more nodes

Actual results:
Deployment is hung up with ~457 deployments IN_PROGRESS.

Error message:
/usr/libexec/os-refresh-config/configure.d/51-hosts: line 17: /bin/awk: Argument list too long

Expected results:
Finish deployment

Additional info:
This bug has been upstream already:
https://bugs.launchpad.net/tripleo/+bug/1674732

And the patch seems to be working.

Comment 1 David Vallee Delisle 2017-08-23 19:25:49 UTC
More output:

~~~
192.168.8.177 servername servername.ctlplane' '/^# HEAT_HOSTS_START/ {
            print $0
            print v
            f=1
            }f &&!/^# HEAT_HOSTS_END$/{next}/^# HEAT_HOSTS_END$/{f=0}!f' /etc/cloud/templates/hosts.redhat.tmpl
/usr/libexec/os-refresh-config/configure.d/51-hosts: line 17: /bin/awk: Argument list too long
[2017-08-23 12:58:45,719] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]

[2017-08-23 12:58:45,719] (os-refresh-config) [ERROR] Aborting...
~~~

Comment 3 Alex Schultz 2017-08-29 21:34:21 UTC

*** This bug has been marked as a duplicate of bug 1484533 ***


Note You need to log in before you can comment on or make changes to this bug.