Bug 1484534 - missing rubygem(proxifier) cause ovirt-hosted-engine-setup failing to install on centos 7.3
Summary: missing rubygem(proxifier) cause ovirt-hosted-engine-setup failing to install...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Packaging.rpm
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ovirt-4.1.5
: ---
Assignee: Sandro Bonazzola
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-23 19:48 UTC by Trent End-Tricky
Modified: 2017-08-24 10:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-24 09:17:48 UTC
oVirt Team: External
rule-engine: ovirt-4.1+


Attachments (Terms of Use)

Description Trent End-Tricky 2017-08-23 19:48:23 UTC
Description of problem:

Error: Package: rubygem-fluent-plugin-secure-forward-0.4.5-1.el7.noarch (centos-opstools-release)                                                               
           Requires: rubygem(proxifier)        


Version-Release number of selected component (if applicable):

oVirt 4.1.5


How reproducible:

It happens for me every time.


Steps to Reproduce:
1. Install centos 7.3 minimal (uk keyboard and localised).
2. sudo yum install http://resources.ovirt.org/pub/yum-repo/ovirt-release41.rpm
3. yum install ovirt-hosted-engine-setup                           
                                              

Actual results:

--> Finished Dependency Resolution                                              
Error: Package: rubygem-fluent-plugin-secure-forward-0.4.5-1.el7.noarch (centos-opstools-release)                                                               
           Requires: rubygem(proxifier)                                         
 You could try using --skip-broken to work around the problem                   
 You could try running: rpm -Va --nofiles --nodigest    

Expected results:

Installation completes without dependency errors.

Additional info:

I have also installed cockpit to assist a remotely managed headless install.  I get this error either way.

Comment 1 Sandro Bonazzola 2017-08-24 08:39:04 UTC
The missing package has been tagged for release and will be on CentOS mirrors in a few hours.

Comment 3 Trent End-Tricky 2017-08-24 10:09:40 UTC
CONFIRM - Install now completes without dependency error.


Note You need to log in before you can comment on or make changes to this bug.