Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1484573 - Is it expected/desired to remove a package to 'resolve' dependencies in its 'update' transaction?
Summary: Is it expected/desired to remove a package to 'resolve' dependencies in its '...
Keywords:
Status: CLOSED DUPLICATE of bug 1446068
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-23 21:54 UTC by Hedayat Vatankhah
Modified: 2017-08-30 06:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-30 06:50:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Hedayat Vatankhah 2017-08-23 21:54:41 UTC
Description of problem:
IMHO, this (the behavior of the last command in following examples) is a weird/undesired behavior (even if it is completely 'logical') (Also note the output of 'dnf update --best --allowerasing firefox' command. You have no clue why firefox is being removed. Maybe the nspr version error should be logged (at least when running in verbose mode) too):

[root@localhost hedayat]# dnf update firefox
Last metadata expiration check: 0:48:29 ago on پنجشنبه ۲۴ اوت ۱۷، ۰۱:۳۱:۱۵.
Dependencies resolved.

 Problem: cannot install the best update candidate for package firefox-55.0.1-1.fc26.x86_64
  - nothing provides nspr >= 4.16.0 needed by firefox-55.0.2-1.fc26.x86_64
================================================================================================================
 Package                  Arch                    Version                        Repository                Size
================================================================================================================
Skipping packages with broken dependencies:
 firefox                  x86_64                  55.0.2-1.fc26                  updates                   82 M

Transaction Summary
================================================================================================================
Skip  1 Package

Nothing to do.
Complete!
[root@localhost hedayat]# dnf update --best firefox
Last metadata expiration check: 0:48:36 ago on پنجشنبه ۲۴ اوت ۱۷، ۰۱:۳۱:۱۵.
Error: 
 Problem: cannot install the best update candidate for package firefox-55.0.1-1.fc26.x86_64
  - nothing provides nspr >= 4.16.0 needed by firefox-55.0.2-1.fc26.x86_64
[root@localhost hedayat]# dnf update --best --allowerasing firefox
Last metadata expiration check: 0:48:45 ago on پنجشنبه ۲۴ اوت ۱۷، ۰۱:۳۱:۱۵.
Dependencies resolved.
================================================================================================================
 Package                Arch                  Version                         Repository                   Size
================================================================================================================
Removing:
 firefox                x86_64                55.0.1-1.fc26                   @localfedora                199 M

Transaction Summary
================================================================================================================
Remove  1 Package

Freed space: 199 M
Is this ok [y/N]: n
Operation aborted.


Version-Release number of selected component (if applicable):
dnf-2.6.3-1.fc26.noarch

How reproducible:
100%

Actual Results:
'dnf update --best --allowerasing firefox' command will completely remove firefox

Expected Result:
'dnf update --best --allowerasing firefox' command should tell me that it cannot update firefox to the latest version, and gives me the reason for it, e.g.   - nothing provides nspr >= 4.16.0 needed by firefox-55.0.2-1.fc26.x86_64

Comment 1 Igor Gnatenko 2017-08-30 06:50:16 UTC
Definitely this is unexpected.... But there is already ticket for this...

*** This bug has been marked as a duplicate of bug 1446068 ***


Note You need to log in before you can comment on or make changes to this bug.