Bug 1484575 - Filesystem resizing during install fails since 2.1.10 (likely due to removal of unconditional filesystem check)
Summary: Filesystem resizing during install fails since 2.1.10 (likely due to removal ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 27
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1490223 (view as bug list)
Depends On:
Blocks: F27FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2017-08-23 22:00 UTC by Adam Williamson
Modified: 2017-10-02 09:05 UTC (History)
13 users (show)

Fixed In Version: python-blivet-2.1.11-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-30 06:41:14 UTC


Attachments (Terms of Use)

Description Adam Williamson 2017-08-23 22:00:28 UTC
blivet 2.1.10 finally 'fixed' https://bugzilla.redhat.com/show_bug.cgi?id=1170803 , so we don't fsck every fsck-able filesystem we find during anaconda startup any more.

However, this seems to have caused another problem: now resizing doesn't actually work any more. I thought there was code to ensure we *did* fsck any filesystem we were actually going to resize before trying to resize it, but it doesn't seem like there is, because the openQA resize test is failing since Fedora-Rawhide-20170818.n.0 (the compose where python-blivet-2.1.10-1.fc28 landed), and the logs suggest it's because the filesystem needs checking before the resize:

16:25:40,156 INF program: stderr:
16:25:40,156 INF program: b'dumpe2fs 1.43.5 (04-Aug-2017)'
16:25:40,156 DBG program: Return code: 0
16:25:40,157 INF program: Running... resize2fs -P /dev/vda1
16:25:40,184 INF program: stdout:
16:25:40,185 INF program: Estimated minimum size of the filesystem: 46097
16:25:40,186 INF program: stderr:
16:25:40,187 INF program: b'resize2fs 1.43.5 (04-Aug-2017)'
16:25:40,187 DBG program: Return code: 0
16:25:40,190 INF program: Running... resize2fs -p /dev/vda1 1193M
16:25:40,217 INF program: stderr:
16:25:40,218 INF program: b'resize2fs 1.43.5 (04-Aug-2017)'
16:25:40,219 INF program: b"Please run 'e2fsck -f /dev/vda1' first."
16:25:40,219 INF program: b''
16:25:40,219 DBG program: Return code: 1

The test goes through the 'guided' workflow, not 'custom' - it uses a pre-built 10GB disk image (created by libguestfs) which contains an ext4 partition taking up the entire disk, then it goes through the 'guided' workflow to the 'reclaim space' screen and uses the size slider on that screen to pick a target size for the partition (usually around 1.15GB). See https://openqa.fedoraproject.org/tests/133578 for an example.

Proposing as an F27 Final blocker, as a violation of Final criterion "Any installer mechanism for resizing storage volumes must correctly attempt the requested operation." - https://fedoraproject.org/wiki/Fedora_27_Final_Release_Criteria#Storage_volume_resize

Comment 1 Vratislav Podzimek 2017-08-29 09:23:49 UTC
https://github.com/storaged-project/blivet/pull/627

Comment 2 Kamil Páral 2017-09-04 17:17:19 UTC
Discussed during blocker review [1]:



[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-09-04/

Comment 3 Kamil Páral 2017-09-04 17:24:42 UTC
Discussed during blocker review [1]:

AcceptedBlocker (Final) - clear violation of Final criterion "Any installer mechanism for resizing storage volumes must correctly attempt the requested operation"

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-09-04/

Comment 4 Adam Williamson 2017-09-12 01:57:18 UTC
For the record, we are still waiting on dlehman's ack/nack for the patch here.

Comment 5 Vratislav Podzimek 2017-09-14 10:11:28 UTC
(In reply to Adam Williamson from comment #4)
> For the record, we are still waiting on dlehman's ack/nack for the patch
> here.

ACKed, merged.

Comment 6 Fedora Update System 2017-09-19 10:15:30 UTC
python-blivet-2.1.11-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7d6391e822

Comment 7 Fedora Update System 2017-09-19 23:29:41 UTC
python-blivet-2.1.11-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7d6391e822

Comment 8 Vojtech Trefny 2017-09-22 07:54:36 UTC
*** Bug 1490223 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2017-09-30 06:41:14 UTC
python-blivet-2.1.11-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.