Bug 1484579 - ImageMagick test failures on big endians
Summary: ImageMagick test failures on big endians
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1484578 (view as bug list)
Depends On:
Blocks: ZedoraTracker PPCTracker
TreeView+ depends on / blocked
 
Reported: 2017-08-23 22:35 UTC by Moez Roy
Modified: 2017-09-11 07:36 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-09-11 07:36:30 UTC


Attachments (Terms of Use)

Description Moez Roy 2017-08-23 22:35:03 UTC
ImageMagick FTBS for arch  ppc64

https://koji.fedoraproject.org/koji/taskinfo?taskID=21429775

Comment 1 Rafael Fonseca 2017-08-23 22:42:30 UTC
And on s390x so probably an endianness issue.

Comment 2 Dan Horák 2017-08-24 07:04:16 UTC
*** Bug 1484578 has been marked as a duplicate of this bug. ***

Comment 3 Dan Horák 2017-08-24 07:30:48 UTC
these are the actual errors (from ImageMagick-7.0.6-9/Magick++/tests/tests.log)

1..13
Line: 49  Horizontal append failed, signature = 3e963245ee5ca5e40977431ad23b5ec759e516f0511a80a21361c7d41cd4f84c
Line: 63  Vertical append failed, signature = 3869872f8e23fa9fb9362e152b778e6a94d2f271339bbcc5b1b5c21d002a1a81
2 failures
not ok
FAIL: Magick++/tests/tests.tap 1
Testing throwing and catching exceptions. A program crash or a message
that the exception was not caught indicates a test failure.  A properly
formatted exception message indicates success:
Caught exception, good!:
  "lt-attributes: unable to open image 'foo': No such file or directory @ error/blob.c/OpenBlob/3109"
Line: 1277, signature (606d5cec3f2ed563d93303e0e1909b81120547abd222481c9fc4932baa59f4ba) is incorrect
Caught exception: lt-attributes: unable to open X server `/home/sharkcz/ImageMagick/ImageMagick-7.0.6-9/utilities/magick display' @ error/display.c/DisplayImages/1685
not ok
FAIL: Magick++/tests/tests.tap 2

Comment 4 Dan Horák 2017-08-24 11:03:59 UTC
for now I have disabled the 2 failing test with
http://pkgs.fedoraproject.org/rpms/ImageMagick/c/9d8a0e0d350a8d02ae40b76ea03f70d118798f23?branch=master


Note You need to log in before you can comment on or make changes to this bug.