Bug 1484609 - Fedora 27 aarch64 installation fails on first boot with 'error: failed to create kernel parameters.'
Summary: Fedora 27 aarch64 installation fails on first boot with 'error: failed to cre...
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 27
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2017-08-24 01:25 UTC by Paul Whalen
Modified: 2017-10-09 20:48 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-10-09 20:48:54 UTC


Attachments (Terms of Use)
anaconda.log (40.70 KB, text/plain)
2017-08-24 01:26 UTC, Paul Whalen
no flags Details
storage.log (218.05 KB, text/plain)
2017-08-24 01:27 UTC, Paul Whalen
no flags Details
program.log (69.80 KB, text/plain)
2017-08-24 01:27 UTC, Paul Whalen
no flags Details
packaging.log (320.00 KB, text/plain)
2017-08-24 01:28 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2017-08-24 01:25:56 UTC
Description of problem:
Fedora-27-20170817.n.3 aarch64 installation fails on first boot with 'error: failed to create kernel parameters.'

Version-Release number of selected component (if applicable):
grub2-2.02-8.fc27

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora-27-20170817.n.3 aarch64
2. Reboot

Actual results:

error: failed to create kernel parameters.

  Failed to boot both default and fallback entries.

Press any key to continue...

Additional info:
Same result with Rawhide, grub2-2.02-10.fc27. Last working with grub2-2.02-6.fc27

Comment 1 Paul Whalen 2017-08-24 01:26 UTC
Created attachment 1317342 [details]
anaconda.log

Comment 2 Paul Whalen 2017-08-24 01:27 UTC
Created attachment 1317344 [details]
storage.log

Comment 3 Paul Whalen 2017-08-24 01:27 UTC
Created attachment 1317345 [details]
program.log

Comment 4 Paul Whalen 2017-08-24 01:28 UTC
Created attachment 1317346 [details]
packaging.log

Comment 5 Jeremy Linton 2017-08-28 15:31:39 UTC
Rawhide-20170827 boots ok now, but the install fails with 


"The package 'grub2-efi' is required for this installation. This package does not
exist. This is a fatal error and installation will be aborted.

Press ENTER to exit:"

Comment 6 Peter Robinson 2017-08-29 13:40:04 UTC
(In reply to Jeremy Linton from comment #5)
> Rawhide-20170827 boots ok now, but the install fails with 
> 
> 
> "The package 'grub2-efi' is required for this installation. This package
> does not
> exist. This is a fatal error and installation will be aborted.
> 
> Press ENTER to exit:"

That should be fixed with https://pagure.io/fedora-comps/pull-request/166 and the next compose


Note You need to log in before you can comment on or make changes to this bug.