Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1484617 - NetworkManager's icon became disconnected after VPN established
Summary: NetworkManager's icon became disconnected after VPN established
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager-openconnect
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-24 02:46 UTC by Aaron Lu
Modified: 2017-10-27 05:40 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-27 05:40:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Aaron Lu 2017-08-24 02:46:03 UTC
Description of problem:
After VPN established, the icon of NetworkManager became 'disconnected' state. Please note that there is no issue using this VPN now, only the icon is wrong.

Version-Release number of selected component (if applicable):
NetworkManager-openconnect-1.2.4-4.fc26.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Connect to some WIFI AP
2. Establish VPN
3. icon became 'disconnected' state after VPN established

Actual results:
icon showed a disconnected state

Expected results:
icon showed a VPN state

Additional info:

Comment 1 Aaron Lu 2017-08-25 12:12:45 UTC
Turned out this problem only occurs under XFCE. Under GNOME, the icon is showing correctly. So...not sure what exactly the problem is.

Fedora 25 doesn't have this issue under XFCE though.

Comment 2 Aaron Lu 2017-08-31 14:04:33 UTC
I think this is more of a adwaita-icon-theme package bug.

Comment 3 Kalev Lember 2017-08-31 14:52:08 UTC
Can you please explain how it's adwaita-icon-theme packaging isue?

Comment 4 Aaron Lu 2017-09-01 04:51:38 UTC
I'm using XFCE with adwaita icon theme.
If I change the icon theme to elementary, the icon of networkmanager didn't show disconnected state after VPN established.
adwaita didn't have problem under GNOME though.

I'm not sure what exactly the problem is, I purely guess it might be related to adwait-icon-theme.

Comment 5 Aaron Lu 2017-09-01 05:49:33 UTC
My mistake. Turned out I mistakenly thought the icon of elementary is correct. Its icon for disconnected state isn't as obvious as adwaita's.

I'll move the bug back to NetworkManager, sorry for the confuse.

Comment 6 Kalev Lember 2017-09-01 05:50:51 UTC
No problem!

Comment 7 Aaron Lu 2017-10-27 05:40:55 UTC
The problem is gone now on F26.

It's not clear which package update fixed it though.


Note You need to log in before you can comment on or make changes to this bug.