Bug 1484651 - [Wayland] Crash when specified profile flag and enabled D-Bus remote backend
Summary: [Wayland] Crash when specified profile flag and enabled D-Bus remote backend
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ffwayland
TreeView+ depends on / blocked
 
Reported: 2017-08-24 04:43 UTC by Hiroshi Hatake
Modified: 2018-01-17 12:16 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-17 12:16:33 UTC


Attachments (Terms of Use)
firefox-wayland with profile crash log (6.53 KB, text/plain)
2017-08-24 04:43 UTC, Hiroshi Hatake
no flags Details
Empty profile name causes SEGV because it makes a wrong D-Bus interface name. (1.06 KB, patch)
2017-08-24 07:05 UTC, Hiroshi Hatake
no flags Details | Diff

Description Hiroshi Hatake 2017-08-24 04:43:13 UTC
Created attachment 1317407 [details]
firefox-wayland with profile crash log

Description of problem:

https://github.com/stransky/gecko-dev or COPR firefox-wayland package.

firefox-wayland-57.1-1.fc26.x86_64
dbus-libs-1.11.14-1.fc26.x86_64
dbus-x11-1.11.14-1.fc26.x86_64
dbus-devel-1.11.14-1.fc26.x86_64

How reproducible:


Steps to Reproduce:
1. Execute firefox-wayland -profile ~/.mozilla/ in GNOME on Wayland environment

Actual results:

firefox-wayland crashes.

Expected results:

Firefox launches normally.

Additional info:

Comment 1 Hiroshi Hatake 2017-08-24 04:43:42 UTC
How reproducible:

Always.

Comment 2 Hiroshi Hatake 2017-08-24 07:05:09 UTC
Created attachment 1317470 [details]
Empty profile name causes SEGV because it makes a wrong D-Bus interface name.

In X11, firefox does not use remote command when profile name is not provided.
Firefox seems not to obtain profile name at startup when users use -profile flag.

Comment 3 Martin Stransky 2017-09-20 09:15:19 UTC
Also we need to change Firefox name in the interface.

Comment 4 Martin Stransky 2018-01-17 12:16:33 UTC
Should be fixed now by https://bugzilla.mozilla.org/show_bug.cgi?id=1429021


Note You need to log in before you can comment on or make changes to this bug.