Bug 1484826 - FreeIPA/IdM installations which were upgraded from versions with 389 DS prior to 1.3.3.0 doesn't have whomai plugin enabled and thus startup of Web UI fails
Summary: FreeIPA/IdM installations which were upgraded from versions with 389 DS prior...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
: 1487501 (view as bug list)
Depends On:
Blocks: 1490331
TreeView+ depends on / blocked
 
Reported: 2017-08-24 11:33 UTC by Petr Vobornik
Modified: 2018-04-10 16:47 UTC (History)
10 users (show)

Fixed In Version: ipa-4.5.0-21.el7.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1490331 (view as bug list)
Environment:
Last Closed: 2018-04-10 16:46:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1478251 None None None 2019-07-23 10:40:08 UTC
Red Hat Product Errata RHBA-2018:0918 None None None 2018-04-10 16:47:24 UTC

Internal Links: 1478251

Description Petr Vobornik 2017-08-24 11:33:31 UTC
Description of problem:
FreeIPA/IdM installations which were created with directory server preceding DS 1.3.3.0 doesn't have DS whoami plugin enabled. 

Whoami plugin is required for whoami IPA API call which is part of Web UI startup. Whoami command is executed after login to get who is the user. With missing plugin entablement this command fails with protocol error and thus loading of Web UI fails.

In httpd error log the error is:

ipa: ERROR: non-public: PROTOCOL_ERROR: {'info': 'unsupported extended operation', 'desc': 'Protocol error'}

Workaround:
Enable the plugin by modifying dse.ldif when DS is shutdown. Or by executing LDAP mod operation as Directory Manager with following ldif:

# whoami, plugins, config
dn: cn=whoami,cn=plugins,cn=config
cn: whoami
nsslapd-plugin-depends-on-type: database
nsslapd-pluginDescription: whoami extended operation plugin
nsslapd-pluginEnabled: on
nsslapd-pluginId: whoami-plugin
nsslapd-pluginInitfunc: whoami_init
nsslapd-pluginPath: libwhoami-plugin
nsslapd-pluginType: extendedop
nsslapd-pluginVendor: 389 Project
nsslapd-pluginVersion: 1.3.6.1
objectClass: top
objectClass: nsSlapdPlugin
objectClass: extensibleObject


Expected results:
If whoami plugin is enabled during IPA upgrade if it is not enabled.

Comment 2 Pavel Vomacka 2017-08-28 15:57:13 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/7126

Comment 5 Petr Vobornik 2017-09-07 17:07:25 UTC
*** Bug 1487501 has been marked as a duplicate of this bug. ***

Comment 6 Petr Vobornik 2017-09-11 10:20:10 UTC
master:
    45bd31b Adds whoami DS plugin in case that plugin is missing
ipa-4-5:
    736a472 Adds whoami DS plugin in case that plugin is missing
ipa-4-6:
    59ef33d Adds whoami DS plugin in case that plugin is missing

Comment 9 Nikhil Dehadrai 2017-12-05 11:39:05 UTC
IPA-server-version: ipa-server-4.5.4-6.el7

Verified the bug on the basis of following observations:
1) Verified that IPA-upgrade is successful using linear upgrade path from RHEL 70z > 71z > 72z > 73z > 74-0day > 74z > 7.5.

2) Also verified that IP servers upgraded from versions with 389 DS prior to 1.3.3.0 doesn't have whomai plugin enabled, are upgraded successfully.

After upgrade:
ldapsearch -xLLL -D 'cn=Directory Manager' -w 'Secret123' -b 'cn=whoami,cn=plugins,cn=config'
dn: cn=whoami,cn=plugins,cn=config
cn: whoami
nsslapd-plugin-depends-on-type: database
nsslapd-pluginDescription: whoami extended operation plugin
nsslapd-pluginEnabled: on
nsslapd-pluginId: whoami-plugin
nsslapd-pluginInitfunc: whoami_init
nsslapd-pluginPath: libwhoami-plugin
nsslapd-pluginType: extendedop
nsslapd-pluginVendor: 389 Project
nsslapd-pluginVersion: 1.3.6.1
objectClass: top
objectClass: nsSlapdPlugin
objectClass: extensibleObject


3) Verified the upgrade for following Direct paths:
-7.4.z > 7.5
-7.4 0-day > 7.5
-7.3.z > 7.5
-7.2.z > 7.5
-7.1.z > 7.5

4) Verified that IPA UI login works after upgrade path in step1 and step3.

Thus on the basis of above observations marking status of bug to "VERIFIED".

Comment 12 errata-xmlrpc 2018-04-10 16:46:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0918


Note You need to log in before you can comment on or make changes to this bug.