Bug 1484845 - flatpak not working out of the box
Summary: flatpak not working out of the box
Status: CLOSED DUPLICATE of bug 1476905
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: flatpak
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David King
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-24 12:05 UTC by M. Scherer
Modified: 2017-08-25 12:36 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-08-25 12:36:12 UTC


Attachments (Terms of Use)

Description M. Scherer 2017-08-24 12:05:44 UTC
Description of problem:
I just installed the flatpak rpm, and it do not work right after installation

Version-Release number of selected component (if applicable):
$ rpm -q flatpak
flatpak-0.8.7-1.el7.x86_64

How reproducible:
each time

Steps to Reproduce:
1. yum install flatpak
2. flatpak
3.

Actual results:

A error message:
$ flatpak                                              
flatpak: error while loading shared libraries: libostree-1.so.1: cannot open shared object file: No such file or directory

Expected results:
A glorious usage message:

$ flatpak
Usage:
  flatpak [OPTION...] COMMAND

Builtin Commands:
 Manage installed apps and runtimes
  install             Install an application or runtime
  update              Update an installed application or runtime
  uninstall           Uninstall an installed application or runtime
  list                List installed apps and/or runtimes
  info                Show info for installed app or runtime



Additional info:

Seems this trick can be used to make it run:

LD_PRELOAD=/usr/lib64/libostree-flatpak-1.so.1.0.0 flatpak

Another trick is to install ostree, since that's what provides the missing file.

The problem is that flatpak provides the same file:

$ rpm -q --whatprovides  "libostree-1.so.1()(64bit)"
flatpak-0.8.7-1.el7.x86_64
ostree-2017.7-1.el7.x86_64

so yum likely decide to install just flatpak and not ostree.

Comment 2 Jiri Koten 2017-08-25 12:36:12 UTC

*** This bug has been marked as a duplicate of bug 1476905 ***


Note You need to log in before you can comment on or make changes to this bug.