Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1484963 - check_disk 2.2.1-4git broken in latest EPEL release
check_disk 2.2.1-4git broken in latest EPEL release
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Stephen John Smoogen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-24 12:52 EDT by Scott Wilkerson
Modified: 2018-07-26 10:52 EDT (History)
9 users (show)

See Also:
Fixed In Version: nagios-plugins-2.2.1-9git5c7eb5b9.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-21 20:41:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Wilkerson 2017-08-24 12:52:42 EDT
Re-posted from https://support.nagios.com/forum/viewtopic.php?f=35&t=45307

Hi,

I found a problem with the latest check_disk release in EPEL. Version 2.2.1-1 is OK, in version 2.2.1-4git the -C/--check option seems to be broken:

2.2.1-1:


[root@master1 ~]# /usr/lib64/nagios/plugins/check_disk -V
check_disk v2.2.1 (nagios-plugins 2.2.1)

[root@master1 ~]# yum list installed | grep nagios-plugins-disk
nagios-plugins-disk.x86_64 2.2.1-1.el7 @stlg-epel-test
nagios-plugins-disk_smb.x86_64 2.2.1-1.el7 @stlg-epel-test

[root@master1 ~]# /usr/lib64/nagios/plugins/check_disk -C
DISK OK - free space: / 28202 MB (74.48% inode=100%); /dev 1413 MB (100.00% inode=100%); /dev/shm 1423 MB (99.99% inode=100%); /run 1279 MB (89.86% inode=100%); /sys/fs/cgroup 1423 MB (100.00% inode=100%); /boot 875 MB (86.37% inode=100%); /vagrant 88040 MB (9.24% inode=100%); /run/user/1000 284 MB (100.00% inode=100%);| /=9658MB;;;0;37861 /dev=0MB;;;0;1413 /dev/shm=0MB;;;0;1423 /run=144MB;;;0;1423 /sys/fs/cgroup=0MB;;;0;1423 /boot=138MB;;;0;1014 /vagrant=864673MB;;;0;952713 /run/user/1000=0MB;;;0;284


2.2.1-4git:


[root@master1 ~]# /usr/lib64/nagios/plugins/check_disk -V
check_disk v2.2.1 (nagios-plugins 2.2.1)

[root@master1 ~]# yum list installed | grep nagios-plugins-disk
nagios-plugins-disk.x86_64 2.2.1-4git.el7 @stlg-epel-test
nagios-plugins-disk_smb.x86_64 2.2.1-4git.el7 @stlg-epel-test

[root@master1 ~]# /usr/lib64/nagios/plugins/check_disk -C
DISK CRITICAL - is not accessible: No such file or directory


OS is CentOS 7.3 on x86_64. The problem can be reproduced on all of my machines.
Comment 1 Stephen John Smoogen 2017-08-25 17:27:55 EDT
[root@el-7 ~]# /usr/lib64/nagios/plugins/check_disk -C
DISK CRITICAL - MESSAGES/nagios-plugins.mo is not accessible: No such file or directory

The git patch was my taking what was in nagios-plugins maint branch and putting it in the package. I will see if I can fix that up next week.

Adding something after the / seems to 'work'
[root@el-7 ~]# /usr/lib64/nagios/plugins/check_disk -C /
DISK OK - free space: / 13894 MB (79.87% inode=99%); /dev 908 MB (100.00% inode=100%); /dev/shm 919 MB (100.00% inode=100%); /run 911 MB (99.08% inode=100%); /sys/fs/cgroup 919 MB (100.00% inode=100%); /boot 737 MB (72.75% inode=100%); /run/user/1000 183 MB (100.00% inode=100%);| /=3499MB;;;0;17394 /dev=0MB;;;0;908 /dev/shm=0MB;;;0;919 /run=8MB;;;0;919 /sys/fs/cgroup=0MB;;;0;919 /boot=276MB;;;0;1014 /run/user/1000=0MB;;;0;183
Comment 2 Peter Eckel 2017-10-12 07:25:45 EDT
is there any news about the status of this issue?
Comment 3 Peter Eckel 2017-11-18 09:17:27 EST
It would be great if at least the version on EPEL could be downgraded to 2.2.1-1 until this is fixed.

EPEL does not seem to offer older versions of repositories, so the only version currently available has been the broken 2.2.1-4git for a while now.
Comment 4 R P Herrold 2017-11-20 15:09:58 EST
Does 
   yum downgrade 
not work?  

       downgrade
              Will  try  and  downgrade  a  package from the version currently
              installed to the previously highest version  (or  the  specified
              version).   The  depsolver will not necessarily work, but if you
              specify all the packages it should work (thus,  all  the  simple
              cases  will  work).  Also  this  does not work for "installonly"
              packages, like Kernels. downgrade  operates  on  groups,  files,
              provides,  filelists  and rpm files just like the "install" com‐
              mand.
Comment 5 Peter Eckel 2017-11-21 06:53:09 EST
Since the older packages are not kept in the EPEL repo, downgrading is not an option when you set up a new server as there isn‘t an older version to downgrade to.
Comment 6 Fedora Update System 2017-11-21 12:54:35 EST
nagios-plugins-2.2.1-9git5c7eb5b9.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-95028b0cf2
Comment 7 Fedora Update System 2017-11-21 13:12:57 EST
nagios-plugins-2.2.1-9.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-e0c04ced36
Comment 8 Fedora Update System 2017-11-21 13:29:18 EST
nagios-plugins-2.2.1-9git5c7eb5b9.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5c6c3ab0a8
Comment 9 Fedora Update System 2017-11-21 14:33:21 EST
nagios-plugins-2.2.1-9git5c7eb5b9.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-95028b0cf2
Comment 10 Peter Eckel 2017-11-24 09:30:48 EST
Sorry - still broken: 

[root@master1 yum.repos.d]# yum list installed | grep nagios-plugins-disk\.*
nagios-plugins-disk.x86_64    2.2.1-9git5c7eb5b9.el7   @epel-testing            

[root@master1 yum.repos.d]# /usr/lib64/nagios/plugins/check_disk -C 
DISK CRITICAL -  ??|"V is not accessible: No such file or directory

[root@master1 yum.repos.d]# /usr/lib64/nagios/plugins/check_disk -C /dev/null
DISK OK - free space: / 32438 MB (85.67% inode=100%); /dev 1413 MB (100.00% inode=100%); /dev/shm 1423 MB (99.99% inode=100%); /run 1399 MB (98.28% inode=100%); /sys/fs/cgroup 1423 MB (100.00% inode=100%); /boot 843 MB (83.16% inode=100%); /run/user/1000 284 MB (100.00% inode=100%); /vagrant 608083 MB (63.82% inode=100%);| /=5423MB;;;0;37861 /dev=0MB;;;0;1413 /dev/shm=0MB;;;0;1423 /run=24MB;;;0;1423 /sys/fs/cgroup=0MB;;;0;1423 /boot=170MB;;;0;1014 /run/user/1000=0MB;;;0;284 /vagrant=344630MB;;;0;952713
Comment 11 Fedora Update System 2017-11-25 00:22:42 EST
nagios-plugins-2.2.1-9git5c7eb5b9.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5c6c3ab0a8
Comment 12 Fedora Update System 2018-04-21 20:41:30 EDT
nagios-plugins-2.2.1-9git5c7eb5b9.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Petr Kyselak 2018-05-25 10:14:30 EDT
Hi, I can confirm the issue is still persist on RHEL7

# rpm -qa | grep nagios
nagios-plugins-2.2.1-9git5c7eb5b9.el7.x86_64

# /usr/lib64/nagios/plugins/check_disk -C
DISK CRITICAL - ��vU is not accessible: No such file or directory

I monitor more partitions but only glusterfs mounted has the issue, other (LVM) are fine and reports correct values. Looks like issue if it is mounted via FUSE.

example:
df -h | grep batXmysql
/dev/mapper/dvg-mysql         2.0T  576G  1.5T  29% /srv/glusterfs/batXmysql
localhost:/batXmysql          2.0T  597G  1.5T  29% /mnt/pacemaker/batXmysql

/usr/lib64/nagios/plugins/check_disk -w 20% -c 10% -p /mnt/pacemaker/batXmysql
DISK CRITICAL - free space: /mnt/pacemaker/batXmysql 0 MB (0.00% inode=100%);| /mnt/pacemaker/batXmysql=610362MB;1677713;1887427;0;2097142


bat1.brno-centrum.cz.ibm.com# /usr/lib64/nagios/plugins/check_disk -w 20% -c 10% -p /var
DISK OK - free space: / 2482 MB (24.84% inode=99%);| /=7507MB;7992;8991;0;9990
Comment 14 Fedora Update System 2018-07-25 18:24:32 EDT
nagios-plugins-2.2.1-14.20180725git3429dad.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-c191412de6
Comment 15 Fedora Update System 2018-07-26 10:52:01 EDT
nagios-plugins-2.2.1-14.20180725git3429dad.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-c191412de6

Note You need to log in before you can comment on or make changes to this bug.