Bug 14850 - Cron should use syslog
Summary: Cron should use syslog
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron   
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-30 15:37 UTC by Jos Vos
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 22:03:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jos Vos 2000-07-30 15:37:00 UTC
Could you distribute vixie-cron with syslog logging enabled?  It requires
one config file change, IIRC, and a small change to the sysklogd package,
as it now includes /var/log/cron as a syslog logfile, included in syslog's
logrotate file, etc.  I have the exact patches needed for both packages, if
you want to see/have them.

We're using modified vixie-cron and sysklogd packages (since RH 3.0.3 or
so) for our customers and it seems to work fine all the time.

Justification:
1. Remote logging now possible for cron.
2. Me was told some time ago that the kill -HUP for crond that's now in
/etc/logrotate.d/cron doesn't work at all (didn't check myself).

Comment 1 Bill Nottingham 2000-08-08 02:35:35 UTC
Fixed in vixie-cron-3.0.1-54, sysklogd-1.3.33-6. Thanks for the continual
reminders. :)


Note You need to log in before you can comment on or make changes to this bug.