Bug 1485008 - subscription-manager register --type="RHUI" or --type="rhui" should both work as documented in various KBase articles
Summary: subscription-manager register --type="RHUI" or --type="rhui" should both work...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-24 20:06 UTC by John Sefler
Modified: 2018-04-10 09:51 UTC (History)
7 users (show)

Fixed In Version: subscription-manager-1.20.2-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-04-10 09:51:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:51:43 UTC
Github candlepin subscription-manager pull 1692 None None None 2017-08-31 11:01:36 UTC
Red Hat Bugzilla 1461003 None CLOSED [RFE] Remove --type option from subscription-manager register 2019-03-21 08:51:04 UTC

Internal Links: 1461003

Description John Sefler 2017-08-24 20:06:18 UTC
Description of problem:
Changes were made in RFE Bug 1461003 to remove the ability for subscription-manager to register using the --type option.  However to maintain compatibility for RHUI consumers, the ability to specify --type="rhui" was silently kept.

The problem is that the previously accepted value for type was case insensitive and there are KBase articles that demonstrate registering with --type=RHUI and --type=rhui.  Therefore subscription-manager should maintain case insensitivity for RHUI. 

Referenced KBase Articles:
https://access.redhat.com/solutions/1171863
https://access.redhat.com/solutions/2959581
https://access.redhat.com/documentation/en-us/red_hat_update_infrastructure/3.0/html/system_administrators_guide/registration_and_subscriptions



Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.40-1
subscription management rules: 5.24.1
subscription-manager: 1.20.1-1.git.27.b65dbce.el7
python-rhsm: 1.20.1-1.git.0.b65dbce.el7


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel7 ~]# subscription-manager register --type=RHUI
Error: The --type option has been deprecated and may not be used.
[root@jsefler-rhel7 ~]# subscription-manager register --type=rHuI
Error: The --type option has been deprecated and may not be used.
[root@jsefler-rhel7 ~]# subscription-manager register --type=rhui
Registering to: subscription.rhsm.redhat.com:443/subscription
Username: qa@redhat.com
Password: 
The system has been registered with ID: 64d2e2d1-48b2-44af-836e-2eb2664e386b 
The registered system name is: jsefler-rhel7.usersys.redhat.com
[root@jsefler-rhel7 ~]# 

Actual results:
above

Expected results:
subscription-manager should allow a case-insensitive RhUi type to pass through to candlepin registration.

Additional info:

Comment 4 Shwetha Kallesh 2017-11-13 09:05:32 UTC
Verified! Subscription-manager allows case-insenstive RHUI and RHui to pass through candlepin registration
[root@dhcp35-121 rhn]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.43-1
subscription management rules: 5.26
subscription-manager: 1.20.5-1.el7

[root@dhcp35-121 rhn]# subscription-manager register --type=RHUI
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: shwetha_tier1_test
Password: 
The system has been registered with ID: 5ad66de6-946b-43c7-b6f4-93e918e278cf
The registered system name is: dhcp35-121.lab.eng.blr.redhat.com
[root@dhcp35-121 rhn]# subscription-manager register --type=rHuI --force
Unregistering from: subscription.rhsm.stage.redhat.com:443/subscription
The system with UUID 5ad66de6-946b-43c7-b6f4-93e918e278cf has been unregistered
All local data removed
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: shwetha_tier1_test
Password: 
The system has been registered with ID: bffc6857-1347-45af-a30a-130c24443eeb
The registered system name is: dhcp35-121.lab.eng.blr.redhat.com
[root@dhcp35-121 rhn]# subscription-manager register --type=rhui --force
Unregistering from: subscription.rhsm.stage.redhat.com:443/subscription
The system with UUID bffc6857-1347-45af-a30a-130c24443eeb has been unregistered
All local data removed
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: shwetha_tier1_test
Password: 
The system has been registered with ID: 5054584c-e048-4756-8731-e3876b04b239
The registered system name is: dhcp35-121.lab.eng.blr.redhat.com

Comment 10 errata-xmlrpc 2018-04-10 09:51:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.