Bug 1485086 - patch or upgrade to kernel v4.14 for AMD APU A9-9410 Kernel hang
Summary: patch or upgrade to kernel v4.14 for AMD APU A9-9410 Kernel hang
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 26
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-25 00:19 UTC by Hin-Tak Leung
Modified: 2017-09-01 03:23 UTC (History)
23 users (show)

Fixed In Version: kernel-4.12.9-300.fc26 kernel-4.12.9-200.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-31 22:53:54 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 100591 0 None None None 2017-08-25 00:19:32 UTC

Description Hin-Tak Leung 2017-08-25 00:19:32 UTC
Description of problem:
See https://bugs.freedesktop.org/show_bug.cgi?id=100591
which points to a patch scheduled for v4.14 :
https://patchwork.kernel.org/patch/9669611/

I bought a new laptop a few weeks ago and tried to put fedora 26 on. It is an Acer Aspire E15. The cheaper model has an Intel Atom(?) CPU but the more expensive one as a "AMD A9-9410 RADEON R5, 5 COMPUTE CORES 2C+3G", according to /proc/cpuinfo .

I had multiple hangs while installing - basically the screen just freezes after a while. I looked on the internet and most says some kernel parameter workaround for the intel cpu, which eventually suggested to me to search for hang problems with my AMD CPU's model name, and found that report.

So, I managed to boot and install successfully by adding amd_iommu=off , and this is needed for every boot from then on, until I get kernel 4.14 .

Version-Release number of selected component (if applicable):
kernel-4.11.8-300.fc26.x86_64 through to
everything later.

How reproducible:
always


Steps to Reproduce:
1. boot without amd_iommu=off on a laptop with a "AMD A9-9410 RADEON R5, 5 COMPUTE CORES 2C+3G" CPU
2.
3.

Actual results:
hangs eventually after a while.

Expected results:
successful usage long-ish term.

Additional info:

Comment 1 Chuck Ebbert 2017-08-25 00:47:45 UTC
Final patch is here in the pci/virtualization tree, queued for 4.14:
https://git.kernel.org/pub/scm/linux/kernel/git/helgaas/pci.git/patch/?id=9b44b0b09decfbe388131a345ba780c57240a7a9

Comment 2 Hin-Tak Leung 2017-08-25 01:10:26 UTC
The symptom for me was not as visible as in https://bugzilla.redhat.com/show_bug.cgi?id=1409201 - as it happened for me during fc26 installation on a new laptop.

Basically after a certain percentage of "Installing packages", the mouse cursor stops spinning. That's it. It could be 50%, it could be 20%, etc. Mouse cursor stop spinning and the percentage mark never went any higher.

I spent about a day installing a few times , because I came upon the workaround to allow the installaton to go to completion. Since then, been adding that option to the kernel parameter mannually for each boot.

Comment 3 Fedora Update System 2017-08-25 21:14:36 UTC
kernel-4.12.9-300.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-78c4c71539

Comment 4 Fedora Update System 2017-08-25 21:15:36 UTC
kernel-4.12.9-200.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4b4c022807

Comment 5 Fedora Update System 2017-08-26 22:36:38 UTC
kernel-4.12.9-300.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-78c4c71539

Comment 6 Fedora Update System 2017-08-26 22:37:39 UTC
kernel-4.12.9-200.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4b4c022807

Comment 7 Fedora Update System 2017-08-31 22:53:54 UTC
kernel-4.12.9-300.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Hin-Tak Leung 2017-08-31 23:14:03 UTC
I don't know if it is related, but about 48 hours after I booted the new kernel,
I was away from the laptop for a while, and when I return, the screen won't light up again, so I close the lid to try to get it to sleep; etc It won't sleep either; so I press the power button eventually. On reboot, I found that the X server was stopping the machine from sleeping. and this concerns the amdgpu part:

Aug 30 00:23:29 localhost kernel: Freezing user space processes ... 
Aug 30 00:23:29 localhost kernel: Freezing of tasks failed after 20.003 seconds (1 tasks refusing to freeze, wq_busy=0):
Aug 30 00:23:29 localhost kernel: Xorg            D    0  1807   1804 0x00000004
Aug 30 00:23:29 localhost kernel: Call Trace:
Aug 30 00:23:29 localhost kernel: __schedule+0x236/0x860
Aug 30 00:23:29 localhost kernel: schedule+0x36/0x80
Aug 30 00:23:29 localhost kernel: amd_sched_entity_push_job+0xc5/0x110 [amdgpu]
Aug 30 00:23:29 localhost kernel: ? finish_wait+0x80/0x80
Aug 30 00:23:29 localhost kernel: amdgpu_job_submit+0x72/0x90 [amdgpu]
Aug 30 00:23:29 localhost kernel: amdgpu_vm_bo_update_mapping+0x2f7/0x360 [amdgpu]
Aug 30 00:23:29 localhost kernel: ? amdgpu_vm_validate_level.isra.8+0x90/0x90 [amdgpu]
Aug 30 00:23:29 localhost kernel: amdgpu_vm_bo_update+0x2d6/0x5b0 [amdgpu]
Aug 30 00:23:29 localhost kernel: amdgpu_gem_va_ioctl+0x4ba/0x4d0 [amdgpu]
Aug 30 00:23:29 localhost kernel: ? drm_gem_object_put_unlocked+0x2e/0x70 [drm]
Aug 30 00:23:29 localhost kernel: drm_ioctl+0x213/0x4d0 [drm]
Aug 30 00:23:29 localhost kernel: ? drm_ioctl+0x213/0x4d0 [drm]
Aug 30 00:23:29 localhost kernel: ? amdgpu_gem_metadata_ioctl+0x1b0/0x1b0 [amdgpu]
Aug 30 00:23:29 localhost kernel: amdgpu_drm_ioctl+0x4f/0x90 [amdgpu]
Aug 30 00:23:29 localhost kernel: do_vfs_ioctl+0xa5/0x600
Aug 30 00:23:29 localhost kernel: SyS_ioctl+0x79/0x90
Aug 30 00:23:29 localhost kernel: entry_SYSCALL_64_fastpath+0x1a/0xa5
Aug 30 00:23:29 localhost kernel: RIP: 0033:0x7f94edba75e7
Aug 30 00:23:29 localhost kernel: RSP: 002b:00007ffc8173bb98 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
Aug 30 00:23:29 localhost kernel: RAX: ffffffffffffffda RBX: 0000000001589b30 RCX: 00007f94edba75e7
Aug 30 00:23:29 localhost kernel: RDX: 00007ffc8173bbe0 RSI: 00000000c0286448 RDI: 000000000000000d
Aug 30 00:23:29 localhost kernel: RBP: 0000000001501d30 R08: 0000000112586000 R09: 000000000000000e
Aug 30 00:23:29 localhost kernel: R10: 0000000000000002 R11: 0000000000000246 R12: 0000000000000000
Aug 30 00:23:29 localhost kernel: R13: 0000000000000001 R14: 000000000158dd80 R15: 0000000001591ec0
Aug 30 00:23:29 localhost kernel: OOM killer enabled.
Aug 30 00:23:29 localhost kernel: Restarting tasks ... done.


So I have gone back to using the amd_iommu=off thing even with the new kernel, as it seems to be more reliable. I could be wrong and this might be unrelated; but it is a bit unpleasant to risk :-(.

Comment 9 Fedora Update System 2017-09-01 03:23:32 UTC
kernel-4.12.9-200.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.