Bug 1485381 - RFE Add support for implied roles to python-openstackclient CLI
Summary: RFE Add support for implied roles to python-openstackclient CLI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstackclient
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M1
: 13.0 (Queens)
Assignee: Harry Rybacki
QA Contact: Prasanth Anbalagan
URL:
Whiteboard:
: 1489883 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-25 14:03 UTC by Harry Rybacki
Modified: 2018-06-27 13:34 UTC (History)
6 users (show)

Fixed In Version: python-openstackclient-3.14.0-0.20180213172604.fbee4eb.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:34:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 290253 None master: MERGED python-openstackclient: Implied Roles (If547c2f16e812bc7fffd742ec37e6a26011f3185) 2018-03-21 13:37:17 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:34:53 UTC

Description Harry Rybacki 2017-08-25 14:03:23 UTC
Although functionality to support use of implied roles e.g. Role A implies, Role B has been built into Keystone. However, the CLI was never expanded to cover this new feature. Please add the ability to create, delete, and list implied roles via the OpenStack CLI.

Comment 2 Red Hat Bugzilla Rules Engine 2017-08-25 14:16:29 UTC
This bugzilla has been removed from the release since it has not been triaged, and needs to be reviewed for targeting another release.

Comment 3 Julie Pichon 2017-10-02 15:36:09 UTC
Note that the upstream patch only merged in Queens/13.

Comment 6 Julie Pichon 2018-02-19 11:15:54 UTC
*** Bug 1489883 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2018-06-27 13:34:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.