Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1485694 - asks about all config files
Summary: asks about all config files
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmconf
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-27 09:17 UTC by Stas Sergeev
Modified: 2017-08-29 12:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-28 10:15:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Stas Sergeev 2017-08-27 09:17:53 UTC
Description of problem:
fedora-upgrade asks about all config files in /etc:
---
Configuration file '/etc/samba/smb.conf'
-rw-r--r-- 1 root root 11353 янв 21  2008 /etc/samba/smb.conf
-rw-r--r-- 1 root root   667 июн 16  2016 /etc/samba/smb.conf.rpmnew

 ==> Package distributor has shipped an updated version.
---

This is ridiculous and makes it completely useless.
Presumably, it asks about those that are changed
between the package versions, but it should only
ask about the ones changed by the user.

Version-Release number of selected component (if applicable):
fedora-upgrade-26.1-1.fc25.noarch

How reproducible:
easily

Steps to Reproduce:
1. fedora-upgrade

Actual results:
Hundreds of silly questions about the config files.

Expected results:
Should only ask about the config files I myself changed.

Additional info:

Comment 1 Miroslav Suchý 2017-08-28 10:15:02 UTC
How should I differ the changes done by yourself?

See this table why .rpmnew are being created:
http://people.ds.cam.ac.uk/jw35/docs/rpm_config.html

If there is .rpmnew file I cannot guess if this was because you modified it. Some tool modified it. Somebody just touched it. Or because it went from %config to %config(noreplace).

Comment 2 Stas Sergeev 2017-08-28 12:41:57 UTC
I really don't know how would you do
that, but when I upgrade ubuntu, I am
not asked 100+ questions about the files
I have never ever touched. I am asked
only about the files I altered myself.
So while I can't suggest you an implementation
details, what I do know is that this
tool is unusable with such implementation.

While spending 10 minutes pressing Y-Enter
as crazy, I have of course missed the
files I really modified. So as the result,
all my configs are now lost, time wasted,
etc.

Comment 3 Miroslav Suchý 2017-08-29 09:02:47 UTC
It took it soo long because you have never done that before. Usually, after the upgrade, I am being asked only 5-7 questions.

Ubuntu/Debian has a different system because configuration management is an integral part of apt. RPM does not do that. So I really cannot do anything about it.

Comment 4 Stas Sergeev 2017-08-29 09:42:39 UTC
You could at least add "Yes for all"
for the person who wanted to give up
pressing Y-Enter. Or have I missed
such a choice?

Comment 5 Miroslav Suchý 2017-08-29 12:10:41 UTC
Yes for all is really not safe.
There is "Skip this step" at the beginning.
And you can always press S as skip.


Note You need to log in before you can comment on or make changes to this bug.