Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1485702 - request backport for "http: Don't wait on CONNECT when there is no proxy"
Summary: request backport for "http: Don't wait on CONNECT when there is no proxy"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: curl
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1485609 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-27 10:53 UTC by Thomas Haller
Modified: 2017-08-29 10:20 UTC (History)
4 users (show)

Fixed In Version: curl-7.55.1-5.fc28 curl-7.55.1-5.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-28 12:24:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Thomas Haller 2017-08-27 10:53:25 UTC
it seems that libcurl 7.55 introduced an issue which causes NetworkManager connectivity check to fail [1]

There is an (already merged) upstream pull request which fixes the issue [2].

Kindly requesting a backport of the fix [3] to the affected releases Fedora 27 and rawhide.


[1] https://bugzilla.gnome.org/show_bug.cgi?id=786432
[2] https://github.com/curl/curl/pull/1803
[3] https://github.com/curl/curl/commit/74dac344b2feb2e0f4baddb70532dc8e45d2d817

Comment 1 Kamil Dudka 2017-08-28 11:32:37 UTC
Sure.  This is easy to backport.  Thanks for the notice!

Comment 2 Kamil Dudka 2017-08-28 11:43:44 UTC
fixed via https://src.fedoraproject.org/rpms/curl/c/b2dab7f3

Comment 3 Bastien Nocera 2017-08-28 11:47:31 UTC
(In reply to Kamil Dudka from comment #2)
> fixed via https://src.fedoraproject.org/rpms/curl/c/b2dab7f3

How about the F27 build?

Comment 4 Kamil Dudka 2017-08-28 12:24:39 UTC
(In reply to Bastien Nocera from comment #3)
> How about the F27 build?

Running...

Comment 5 Kamil Dudka 2017-08-29 10:19:55 UTC
*** Bug 1485609 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.