Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1485728 - python3 won't update to latest version available because python3-docs depends on earlier version
Summary: python3 won't update to latest version available because python3-docs depends...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python3-docs
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Iryna Shcherbina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-27 17:09 UTC by stan
Modified: 2017-09-10 04:50 UTC (History)
5 users (show)

Fixed In Version: python3-docs-3.5.4-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-10 04:50:23 UTC
Type: Bug


Attachments (Terms of Use)

Description stan 2017-08-27 17:09:48 UTC
Description of problem:
There is a newer version of python3 available for F25, 3.5.4-1, but it can't install because the version of python3-docs installed requires python3 3.5.3-1

Version-Release number of selected component (if applicable):
Name        : python3-docs
Version     : 3.5.3
Release     : 1.fc25
Architecture: noarch

How reproducible:
Every time

Steps to Reproduce:
1.  Have python3 and python3-docs 3.5.3-1 installed
2.  Try to update to python3 3.5.4-1
3.

Actual results:
Package conflict prevents update

Expected results:
All packages update

Additional info:
Seems that python3-docs just needs to be built for the latest version of python3 in F25

Comment 1 Tomas Orsava 2017-08-28 13:21:44 UTC
I added a warning to the python3 spec file so this hopefully doesn't happen again in the future. Thanks for the heads up, stan!

Comment 2 stan 2017-08-28 18:11:14 UTC
Thank you for the fast response, and the future proofing.

Comment 3 Fedora Update System 2017-09-01 12:52:56 UTC
python3-docs-3.5.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-bf2721cc81

Comment 4 Fedora Update System 2017-09-10 04:50:23 UTC
python3-docs-3.5.4-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.