Bug 1485795 - After installing ceph-medic on Ubuntu, got ImportError, for module tambo
Summary: After installing ceph-medic on Ubuntu, got ImportError, for module tambo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Medic
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 3.0
Assignee: Andrew Schoen
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-28 06:28 UTC by Shreekar
Modified: 2017-12-05 23:41 UTC (History)
5 users (show)

Fixed In Version: ceph-medic_1.0.2-3redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-05 23:41:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3387 0 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC

Description Shreekar 2017-08-28 06:28:21 UTC
Description of problem:
After installing ceph-medic on Ubuntu,using ceph-ansible_3.0.0~rc3-2redhat1 for Ubuntu, got this ImportError ,for module tambo. 

Repo link--http://download.eng.pek2.redhat.com/rcm-guest/ceph-drops/3.0/RHCEPH-3.0-Ubuntu-x86_64-20170817.t.0/


Version-Release number of selected component (if applicable):
ceph-ansible_3.0.0~rc3-2redhat1
ceph-medic 1.0.2



How reproducible:
Always

Steps to Reproduce:
1.By installing tambo module, issue was resolved.
  "python2.7 -m pip install tambo"

Actual results:

Traceback (most recent call last):
  File "/usr/bin/ceph-medic", line 3, in <module>
    from ceph_medic import main
  File "/usr/lib/python2.7/dist-packages/ceph_medic/main.py", line 1, in <module>
    from ceph_medic import check, log
  File "/usr/lib/python2.7/dist-packages/ceph_medic/check.py", line 5, in <module>
    from tambo import Transport
ImportError: No module named tambo


Expected results:
For command ceph-medic ,suppose to display help.

Additional info:

Comment 2 Alfredo Deza 2017-08-30 12:42:34 UTC
We were relying on that package being available in RHEL, but I am unsure what the status is for a DEB package. Ken do you know what, if anything, is preventing this from being available?

Comment 3 Ken Dreyer (Red Hat) 2017-08-30 13:13:13 UTC
We have a deb package for python-tambo, and it's present in the latest compose: python-tambo_0.4.0-2redhat1_all.deb

Would you please confirm that "apt-get -y install python-tambo" works around this problem? (Please never use pip to install packages; there is no integrity checking for customers)

I will investigate why "apt-get install ceph-medic" did not pull in python-tambo.

Comment 4 Ken Dreyer (Red Hat) 2017-08-31 14:46:06 UTC
dh_python2 did not automatically add the dependency on the tambo package because it was not in the Build-Depends list. I didn't notice the missing Build-Depends on the tambo package because the v1.0.2 test suite passes without it.

https://github.com/ceph/ceph-medic/pull/56 adds a test that exercises the piece of CLI code that loads tambo so we cover that for the future.

Comment 7 Shreekar 2017-09-06 07:32:19 UTC
Bug verified

Comment 10 errata-xmlrpc 2017-12-05 23:41:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.