Bug 1485851 - ipa param-find: command displays internal error
Summary: ipa param-find: command displays internal error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-28 09:09 UTC by Sudhir Menon
Modified: 2018-10-30 10:56 UTC (History)
6 users (show)

Fixed In Version: ipa-4.6.4-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:56:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3187 0 None None None 2018-10-30 10:56:48 UTC

Description Sudhir Menon 2017-08-28 09:09:49 UTC
Description of problem: ipa param-find: command displays internal error


Version-Release number of selected component (if applicable):
ipa-server-4.5.0-21.el7_4.1.x86_64

How reproducible: Always


Steps to Reproduce:
1. ipa help schema
2. Run the below commands.
3. ipa class-show test
4. ipa command-show test
5. ipa output-show test
6. ipa param-show test
7. ipa topic-show test
8. ipa param-find test



Actual results:
3. ipa: ERROR: test: class not found
4. ipa: ERROR: test: command not found
5. Name: test ipa: ERROR: an internal error has occurred
6. Name: test ipa: ERROR: an internal error has occurred
7. ipa: ERROR: test: topic not found
8. ipa: ERROR: an internal error has occurred


[Mon Aug 28 04:53:41.864238 2017] [:error] [pid 18874] ipa: ERROR: non-public: KeyError: u'test'
[Mon Aug 28 04:53:41.864297 2017] [:error] [pid 18874] Traceback (most recent call last):
[Mon Aug 28 04:53:41.864307 2017] [:error] [pid 18874]   File "/usr/lib/python2.7/site-packages/ipaserver/rpcserver.py", line 367, in wsgi_execute
[Mon Aug 28 04:53:41.864315 2017] [:error] [pid 18874]     result = command(*args, **options)
[Mon Aug 28 04:53:41.864323 2017] [:error] [pid 18874]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 447, in __call__
[Mon Aug 28 04:53:41.864331 2017] [:error] [pid 18874]     return self.__do_call(*args, **options)
[Mon Aug 28 04:53:41.864339 2017] [:error] [pid 18874]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 475, in __do_call
[Mon Aug 28 04:53:41.864347 2017] [:error] [pid 18874]     ret = self.run(*args, **options)
[Mon Aug 28 04:53:41.864355 2017] [:error] [pid 18874]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 797, in run
[Mon Aug 28 04:53:41.864363 2017] [:error] [pid 18874]     return self.execute(*args, **options)
[Mon Aug 28 04:53:41.864371 2017] [:error] [pid 18874]   File "/usr/lib/python2.7/site-packages/ipaserver/plugins/schema.py", line 112, in execute
[Mon Aug 28 04:53:41.864379 2017] [:error] [pid 18874]     obj = self.obj.retrieve(*args, **options)
[Mon Aug 28 04:53:41.864386 2017] [:error] [pid 18874]   File "/usr/lib/python2.7/site-packages/ipaserver/plugins/schema.py", line 81, in retrieve
[Mon Aug 28 04:53:41.864394 2017] [:error] [pid 18874]     obj = self._retrieve(*args, **kwargs)
[Mon Aug 28 04:53:41.864402 2017] [:error] [pid 18874]   File "/usr/lib/python2.7/site-packages/ipaserver/plugins/schema.py", line 717, in _retrieve
[Mon Aug 28 04:53:41.864410 2017] [:error] [pid 18874]     cmd = self.api.Command[commandfull_name]
[Mon Aug 28 04:53:41.864418 2017] [:error] [pid 18874]   File "/usr/lib/python2.7/site-packages/ipalib/plugable.py", line 325, in __getitem__
[Mon Aug 28 04:53:41.864426 2017] [:error] [pid 18874]     plugin = self.get_plugin(key)
[Mon Aug 28 04:53:41.864433 2017] [:error] [pid 18874]   File "/usr/lib/python2.7/site-packages/ipalib/plugable.py", line 322, in get_plugin
[Mon Aug 28 04:53:41.864441 2017] [:error] [pid 18874]     return self.__plugins_by_key[key]
[Mon Aug 28 04:53:41.864449 2017] [:error] [pid 18874] KeyError: u'test'
[Mon Aug 28 04:53:41.865148 2017] [:error] [pid 18874] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: output_show/1(u'test', u'test', version=u'2.228'): InternalError
[Mon Aug 28 04:53:57.226092 2017] [:warn] [pid 18877] [client 10.19.34.88:37000] failed to set perms (3140) on file (/var/run/ipa/ccaches/admin@TESTRELM.TEST)!, referer: https://cypher.testrelm.test/ipa/xml
[Mon Aug 28 04:53:57.298204 2017] [:error] [pid 18875] ipa: ERROR: non-public: KeyError: u'test'
[Mon Aug 28 04:53:57.298258 2017] [:error] [pid 18875] Traceback (most recent call last):
[Mon Aug 28 04:53:57.298268 2017] [:error] [pid 18875]   File "/usr/lib/python2.7/site-packages/ipaserver/rpcserver.py", line 367, in wsgi_execute
[Mon Aug 28 04:53:57.298304 2017] [:error] [pid 18875]     result = command(*args, **options)
[Mon Aug 28 04:53:57.298313 2017] [:error] [pid 18875]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 447, in __call__
[Mon Aug 28 04:53:57.298321 2017] [:error] [pid 18875]     return self.__do_call(*args, **options)
[Mon Aug 28 04:53:57.298329 2017] [:error] [pid 18875]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 475, in __do_call
[Mon Aug 28 04:53:57.298337 2017] [:error] [pid 18875]     ret = self.run(*args, **options)
[Mon Aug 28 04:53:57.298344 2017] [:error] [pid 18875]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 797, in run
[Mon Aug 28 04:53:57.298352 2017] [:error] [pid 18875]     return self.execute(*args, **options)
[Mon Aug 28 04:53:57.298360 2017] [:error] [pid 18875]   File "/usr/lib/python2.7/site-packages/ipaserver/plugins/schema.py", line 112, in execute
[Mon Aug 28 04:53:57.298368 2017] [:error] [pid 18875]     obj = self.obj.retrieve(*args, **options)
[Mon Aug 28 04:53:57.298376 2017] [:error] [pid 18875]   File "/usr/lib/python2.7/site-packages/ipaserver/plugins/schema.py", line 81, in retrieve
[Mon Aug 28 04:53:57.298384 2017] [:error] [pid 18875]     obj = self._retrieve(*args, **kwargs)
[Mon Aug 28 04:53:57.298392 2017] [:error] [pid 18875]   File "/usr/lib/python2.7/site-packages/ipaserver/plugins/schema.py", line 631, in _retrieve
[Mon Aug 28 04:53:57.298400 2017] [:error] [pid 18875]     metaobj = self.api.Object[metaobjectfull_name]
[Mon Aug 28 04:53:57.298407 2017] [:error] [pid 18875]   File "/usr/lib/python2.7/site-packages/ipalib/plugable.py", line 325, in __getitem__
[Mon Aug 28 04:53:57.298415 2017] [:error] [pid 18875]     plugin = self.get_plugin(key)
[Mon Aug 28 04:53:57.298423 2017] [:error] [pid 18875]   File "/usr/lib/python2.7/site-packages/ipalib/plugable.py", line 322, in get_plugin
[Mon Aug 28 04:53:57.298431 2017] [:error] [pid 18875]     return self.__plugins_by_key[key]
[Mon Aug 28 04:53:57.298439 2017] [:error] [pid 18875] KeyError: u'test'


Expected results:
Internal error should be fixed with valid error messages as seen in 3 and 4.

Additional info:

Comment 2 Petr Vobornik 2017-09-01 22:20:41 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/7138

Comment 3 Petr Vobornik 2017-09-01 22:24:51 UTC
there is already existing upstream ticket which was not linked correctly, fixing:
https://pagure.io/freeipa/issue/7134

Comment 8 Sudhir Menon 2018-08-07 08:42:14 UTC
Fix is seen. 
Verified on Red Hat Enterprise Linux Server release 7.6 Beta (Maipo)  using

ipa-server-4.6.4-3.el7.x86_64
sssd-1.16.2-11.el7.x86_64
389-ds-base-1.3.8.4-9.el7.x86_64
krb5-server-1.15.1-34.el7.x86_64
pki-server-10.5.9-4.el7.noarch
selinux-policy-3.13.1-211.el7.noarch


[root@master ~]# ipa class-show test
ipa: ERROR: test: class not found
[root@master ~]# ipa command-show test
ipa: ERROR: test: command not found
[root@master ~]# ipa output-show test
Name: test
ipa: ERROR: test: output not found
[root@master ~]# ipa param-show test
Name: test
ipa: ERROR: test: param not found
[root@master ~]# ipa topic-show test
ipa: ERROR: test: topic not found
[root@master ~]# ipa param-find test
----------------------------
Number of entries returned 0
----------------------------

[root@master ~]# ipa param-find
Full name: 
ipa: ERROR: 'metaobject' is required
[root@master ~]# ipa param-find user-find
  Name: criteria
  Documentation: A string searched in all relevant object attributes
  Type: str
  Required: False
  Positional argument: True

Comment 10 errata-xmlrpc 2018-10-30 10:56:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3187


Note You need to log in before you can comment on or make changes to this bug.