Bug 1485881 - DNF claims it cannot install package, which have been already installed
Summary: DNF claims it cannot install package, which have been already installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libdnf
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-28 10:57 UTC by Miroslav Suchý
Modified: 2017-10-04 22:24 UTC (History)
10 users (show)

Fixed In Version: libdnf-0.10.1-1.fc27 libdnf-0.10.1-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-04 14:22:31 UTC


Attachments (Terms of Use)

Description Miroslav Suchý 2017-08-28 10:57:22 UTC
I have firefox-55.0.2-2.fc26.x86_64 installed on my machine, but when I run dnf it state firefox (with the same NEVRA) cannot be installed because of conflicts.

# rpm -q firefox dnf nspr
firefox-55.0.2-2.fc26.x86_64
dnf-2.6.3-1.git.13.f1cca7e.fc26.noarch
nspr-4.15.0-1.fc26.x86_64
nspr-4.15.0-1.fc26.i686

# dnf upgrade
...
Last metadata expiration check: 0:17:10 ago on Mon 28 Aug 2017 12:34:57 PM CEST.                                                                      
Dependencies resolved.                                                                                                                                
                                                                                                                                                      
 Problem 1: cannot install the best update candidate for package VirtualBox-guest-additions-5.1.22-1.fc27.x86_64                                      
  - nothing provides VirtualBox-kmod = 5.1.26 needed by VirtualBox-guest-additions-5.1.26-2.fc27.x86_64                                               
 Problem 2: package firefox-55.0.2-2.fc26.x86_64 conflicts with pkgconfig(nspr) >= 4.16 provided by nspr-devel-4.16.0-1.fc26.x86_64                   
  - cannot install the best update candidate for package nspr-devel-4.15.0-1.fc26.x86_64                                                              
  - cannot install the best update candidate for package firefox-55.0.2-2.fc26.x86_64                                                                 
 Problem 3: problem with installed package firefox-55.0.2-2.fc26.x86_64                                                                               
  - package firefox-55.0.2-2.fc26.x86_64 conflicts with pkgconfig(nspr) >= 4.16 provided by nspr-devel-4.16.0-1.fc26.x86_64                           
  - problem with installed package nspr-devel-4.15.0-1.fc26.x86_64                                                                                    
  - package nspr-devel-4.15.0-1.fc26.x86_64 requires nspr = 4.15.0-1.fc26, but none of the providers can be installed                                 
  - cannot install both nspr-4.16.0-1.fc26.i686 and nspr-4.15.0-1.fc26.i686                                                                           
  - cannot install both nspr-4.16.0-1.fc26.x86_64 and nspr-4.15.0-1.fc26.x86_64                                                                       
  - cannot install the best update candidate for package nspr-4.15.0-1.fc26.i686                                                                      
  - cannot install the best update candidate for package nspr-4.15.0-1.fc26.x86_64                                                                    
======================================================================================================================================================
 Package                                      Arch                     Version                         Repository                                Size
======================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 firefox                                      x86_64                   55.0.2-2.fc26                   updates                                   82 M
 nspr                                         i686                     4.16.0-1.fc26                   updates                                  143 k
 nspr                                         x86_64                   4.16.0-1.fc26                   updates                                  137 k
 nspr-devel                                   x86_64                   4.16.0-1.fc26                   updates                                  119 k
Skipping packages with broken dependencies:
 VirtualBox-guest-additions                   x86_64                   5.1.26-2.fc27                   rpmfusion-free-rawhide                   1.6 M

Transaction Summary
======================================================================================================================================================
Skip  5 Packages

Nothing to do.

The problem is that nspr cannot be installed. So the error is in fact correct, but the wording is not right. It should not state that firefox cannot be installed, because that is already installed. It should say that nspr cannot be installed because of conflict with firefox.

Comment 1 Igor Gnatenko 2017-08-28 13:14:07 UTC
it's firefox conflicting with nspr rather ;)

Comment 2 Panu Matilainen 2017-08-28 14:06:46 UTC
Whatever, but firefox shouldn't be on the "skipping packages with conflicts" list because it was already installed. I'm seeing this situation on my systems too.

Comment 3 Miroslav Suchý 2017-08-30 10:38:41 UTC
Here comes PR which should fix this issue.
https://github.com/rpm-software-management/libdnf/pull/322

Comment 4 Jaroslav Mracek 2017-08-30 16:19:32 UTC
Thanks Miroslav for the report

Comment 5 Fedora Update System 2017-10-02 10:32:37 UTC
dnf-plugins-extras-2.0.3-1.fc27 dnf-plugins-core-2.1.4-1.fc27 dnf-2.7.2-1.fc27 libdnf-0.10.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-faf235c683

Comment 6 Fedora Update System 2017-10-02 10:36:52 UTC
dnf-plugins-extras-2.0.3-1.fc26 dnf-plugins-core-2.1.4-1.fc26 dnf-2.7.2-1.fc26 libdnf-0.10.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-70a8618065

Comment 7 Fedora Update System 2017-10-02 20:27:44 UTC
dnf-2.7.2-1.fc26, dnf-plugins-core-2.1.4-1.fc26, dnf-plugins-extras-2.0.3-1.fc26, libdnf-0.10.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-70a8618065

Comment 8 Fedora Update System 2017-10-02 21:27:06 UTC
dnf-2.7.2-1.fc27, dnf-plugins-core-2.1.4-1.fc27, dnf-plugins-extras-2.0.3-1.fc27, libdnf-0.10.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-faf235c683

Comment 9 Fedora Update System 2017-10-04 14:22:31 UTC
dnf-2.7.2-1.fc27, dnf-plugins-core-2.1.4-1.fc27, dnf-plugins-extras-2.0.3-1.fc27, libdnf-0.10.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-10-04 22:24:43 UTC
dnf-2.7.2-1.fc26, dnf-plugins-core-2.1.4-1.fc26, dnf-plugins-extras-2.0.3-1.fc26, libdnf-0.10.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.