Bug 1485992 - Unit tests failing on CI
Summary: Unit tests failing on CI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: zstream
: 7.0 (Kilo)
Assignee: anil venkata
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-28 16:10 UTC by anil venkata
Modified: 2017-10-25 17:05 UTC (History)
5 users (show)

Fixed In Version: openstack-neutron-2015.1.4-22.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-25 17:05:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3069 0 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2017-10-25 21:02:55 UTC

Description anil venkata 2017-08-28 16:10:06 UTC
Description of problem:

On OSP7, following unit tests which are added by commits[1] are not tested properly and are constantly failing on CI [2]. 
test_initialize_and_delete_fail_retrigger_initialize
test_initialize_fail_retrigger_initialize
test_sync_routers_not_calls_updates_ha_network_port_status
test_sync_routers_updates_ha_network_port_status

[1] a617406e6a3074d089b8ddbbffbcf706520f7503
b2c36b1188610dd9d2c6b83df62b983cbe149fbe

[2] https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/DFG-network-neutron-7-unit-rhos/11/

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 anil venkata 2017-09-26 05:19:31 UTC
Build openstack-neutron-2015.1.4-22.el7ost already provided with the fix.

Comment 3 Assaf Muller 2017-09-29 19:03:06 UTC
Recent job runs show the tests are now passing.

Comment 6 errata-xmlrpc 2017-10-25 17:05:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3069


Note You need to log in before you can comment on or make changes to this bug.