Bug 1486127 - Fix permission mismatch of vhost-user sockets for DPDK on containerized deployment
Summary: Fix permission mismatch of vhost-user sockets for DPDK on containerized deplo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 12.0 (Pike)
Assignee: Emilien Macchi
QA Contact: Yariv
URL:
Whiteboard:
: 1485945 (view as bug list)
Depends On:
Blocks: 1416430 1485945 1499673
TreeView+ depends on / blocked
 
Reported: 2017-08-29 06:33 UTC by Saravanan KR
Modified: 2018-02-05 19:12 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-7.0.3-0.20171023134947.8da5e1f.el7ost, openstack-tripleo-common-7.6.3-0.20171022171807.f27b723.el7ost.
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1499673 (view as bug list)
Environment:
Last Closed: 2017-12-13 21:58:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1712732 None None None 2017-08-30 07:18:02 UTC
OpenStack gerrit 501696 None MERGED Added a kolla config file for building contaner images with qemu uid 2020-10-19 17:14:06 UTC
OpenStack gerrit 501980 None MERGED Mount vhost_sockets directory for vhost-user socket creation 2020-10-19 17:14:06 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Saravanan KR 2017-08-29 06:33:10 UTC
Description of problem:

Creating a guest VM on DPDK network fails because of vhost-user socket permission mismatch. Details discussed here - http://lists.openstack.org/pipermail/openstack-dev/2017-August/121487.html

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Mike Burns 2017-09-13 13:32:21 UTC
*** Bug 1491201 has been marked as a duplicate of this bug. ***

Comment 3 Saravanan KR 2017-10-09 08:38:29 UTC
Downstream image building is handled via BZ #1491201, I will separate the upstream image building change to separate BZ from this one.

Comment 4 Saravanan KR 2017-10-23 10:09:07 UTC
*** Bug 1485945 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2017-12-13 21:58:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.