Bug 1486318 - /usr/bin/net doesn't work without /var/lib/samba/lock
Summary: /usr/bin/net doesn't work without /var/lib/samba/lock
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: Andrej Dzilský
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-29 13:08 UTC by Dominik Mierzejewski
Modified: 2018-04-10 17:29 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-10 17:28:22 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0937 None None None 2018-04-10 17:29 UTC

Description Dominik Mierzejewski 2017-08-29 13:08:43 UTC
Description of problem:
/usr/bin/net tool doesn't work if /var/lib/samba/lock directory doesn't exist. samba package isn't installed

Version-Release number of selected component (if applicable):
$ rpm -qa samba\*
samba-client-libs-4.6.2-8.el7.x86_64
samba-libs-4.6.2-8.el7.x86_64
samba-common-4.6.2-8.el7.noarch
samba-common-tools-4.6.2-8.el7.x86_64
samba-common-libs-4.6.2-8.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install samba-common-tools
2. yum remove samba
3. (as non-root user) /usr/bin/net help

Actual results:
mkdir failed on directory /var/lib/samba/lock: Permission denied
Failed to init messaging context

Expected results:
$ /usr/bin/net help
mkdir failed on directory /var/lib/samba/lock/msg.lock: Permission denied
Usage:
net rpc             Run functions using RPC transport
net rap             Run functions using RAP transport
[...]

Additional info:
Manually creating the directory as root works around this issue.
It looks like /var/lib/samba/lock is owned by the samba package. Perhaps it should be moved to samba-common?

Comment 6 errata-xmlrpc 2018-04-10 17:28:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0937


Note You need to log in before you can comment on or make changes to this bug.