Bug 1486611 - [UPSTREAM] 500 Internal Server Error : uninitialized constant StorageManager
Summary: [UPSTREAM] 500 Internal Server Error : uninitialized constant StorageManager
Keywords:
Status: CLOSED DUPLICATE of bug 1503716
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: cfme-future
Assignee: Martin Povolny
QA Contact: Vatsal Parekh
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-30 09:12 UTC by Vatsal Parekh
Modified: 2017-10-31 13:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-31 13:44:49 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
production log (25.73 KB, text/plain)
2017-08-30 09:12 UTC, Vatsal Parekh
no flags Details

Description Vatsal Parekh 2017-08-30 09:12:10 UTC
Created attachment 1319945 [details]
production log

Description of problem:
After adding the provider RHOS7-GA, went to the storage managers, it gives the error 
URL /ems_cloud/report_data

Status 500 Internal Server Error

Content-Type text/html; charset=utf-8

Data uninitialized constant StorageManager [ems_cloud/report_data]

Version-Release number of selected component (if applicable):
Version master.20170830023820_aa4dab9

How reproducible:
100%

Steps to Reproduce:
1.Add provider(here rhos7-ga)
2.Inside provider, Storage manager
3.

Actual results:
500 Internal error

Expected results:
Should show the storage managers, or if not found, should show appropriate message

Additional info:
Please check the attached production log

Comment 3 Martin Povolny 2017-10-31 13:44:49 UTC

*** This bug has been marked as a duplicate of bug 1503716 ***


Note You need to log in before you can comment on or make changes to this bug.