Bug 1486664 - [UI] - UI Exception when going to Host Devices under Hosts
Summary: [UI] - UI Exception when going to Host Devices under Hosts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
low vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Alexander Wels
QA Contact: samuel macko
URL:
Whiteboard:
: 1494911 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-30 10:35 UTC by Michael Burman
Modified: 2017-12-20 11:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:03:34 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
ui log (39.88 KB, application/x-gzip)
2017-08-30 10:35 UTC, Michael Burman
no flags Details
record1 (1.51 MB, application/x-gzip)
2017-08-30 10:38 UTC, Michael Burman
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 81108 0 None None None 2017-08-30 19:21:11 UTC

Description Michael Burman 2017-08-30 10:35:19 UTC
Created attachment 1319987 [details]
ui log

Description of problem:
[UI] - UI Exception when going to Host Devices under Hosts.


2017-08-30 13:31:42,347+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-12) [] Permutation name: 76FCCE10EDC5D694A622CA0726B5D1EE
2017-08-30 13:31:42,348+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-12) [] Uncaught exception: com.google.gwt.core.client.JavaScriptException: (TypeError) : Cannot read property 'nh' of null
        at java.lang.String.join(String.java:123) [rt.jar:1.8.0_131]
        at org.ovirt.engine.ui.webadmin.section.main.view.tab.host.HostDeviceModelBaseTable$7.getValue(HostDeviceModelBaseTable.java:71)
        at com.google.gwt.user.cellview.client.Column.render(Column.java:164) [gwt-servlet.jar:]
Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170828065003.git0619c76.el7.centos

How reproducible:
100% 

Steps to Reproduce:
1. Go to Hosts > specific host > 'Host Devices' sub tab 

Actual results:
UI exception - (TypeError) : Cannot read property 'nh' of null

Expected results:
NO exceptions

Comment 1 Michael Burman 2017-08-30 10:38:03 UTC
Created attachment 1319989 [details]
record1

Comment 2 samuel macko 2017-09-04 10:26:21 UTC
Verified in ovirt version 4.2.0-0.0.master.20170903205106.gitb17261a.el7.centos.

Verified by following the reproducer.

Comment 3 Tomas Jelinek 2017-09-27 07:30:13 UTC
*** Bug 1494911 has been marked as a duplicate of this bug. ***

Comment 4 Sandro Bonazzola 2017-12-20 11:03:34 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.