Bug 1486694 - hammer content-view info doesn't show components of a composite CV
Summary: hammer content-view info doesn't show components of a composite CV
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-30 11:22 UTC by Tomas Strachota
Modified: 2019-08-12 14:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-01 12:07:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tomas Strachota 2017-08-30 11:22:35 UTC
Description of problem:

The info command doesn't show components of a composite CV.


Version-Release number of selected component (if applicable):
hammer_cli_katello (0.10.0)


Steps to Reproduce:
1. Create content views "CV A" and "CV B"
2. Create a composite content view "CV Composite", set "CV A" and "CV B" as its components
3. Use hammer content-view info to view details of "CV Composite"
4. The components "CV A" and "CV B" aren't listed


Actual results:
The components list is empty.


Expected results:
The command should print list of components under the label "Components:"


Additional info:

API returns arrays "components" (empty) and "content_view_components", hammer seems to be using the first one:

                 "components" => [],
     "content_view_components" => [
        [0] {
                            "latest" => true,
                                "id" => 1,
                        "created_at" => "2017-08-23 11:15:33 UTC",
                        "updated_at" => "2017-08-23 11:15:33 UTC",
            "composite_content_view" => {
                            "id" => 5,
                          "name" => "CV Composite",
                         "label" => "CV_Composite",
                   "description" => nil,
                  "next_version" => 1,
                "latest_version" => nil,
                 "version_count" => 0
            },
                      "content_view" => {
                            "id" => 3,
                          "name" => "CV A",
                         "label" => "CV_A",
                   "description" => nil,
                  "next_version" => 1,
                "latest_version" => nil,
                 "version_count" => 0
            },
              "content_view_version" => nil
        },
        [1] {
                            "latest" => true,
                                "id" => 2,
                        "created_at" => "2017-08-23 11:15:33 UTC",
                        "updated_at" => "2017-08-23 11:15:33 UTC",
            "composite_content_view" => {
                            "id" => 5,
                          "name" => "CV Composite",
                         "label" => "CV_Composite",
                   "description" => nil,
                  "next_version" => 1,
                "latest_version" => nil,
                 "version_count" => 0
            },
                      "content_view" => {
                            "id" => 4,
                          "name" => "CV B",
                         "label" => "CV_B",
                   "description" => nil,
                  "next_version" => 1,
                "latest_version" => nil,
                 "version_count" => 0
            },
              "content_view_version" => nil
        }
    ],

Comment 2 Bryan Kearney 2019-02-28 19:40:47 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 3 Bryan Kearney 2019-04-01 12:07:06 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.

Comment 4 Bryan Kearney 2019-04-02 13:33:48 UTC
Wrond closure reason.


Note You need to log in before you can comment on or make changes to this bug.