Bug 1486703 - neutron-ml2-ovn-ha.yaml display incorrect parameter values -NeutronTypeDrivers: 'geneve,vxlan,vlan,flat'
Summary: neutron-ml2-ovn-ha.yaml display incorrect parameter values -NeutronTypeDriver...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Upstream M1
: 13.0 (Queens)
Assignee: Assaf Muller
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-30 11:47 UTC by Eran Kuris
Modified: 2018-06-27 13:34 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180227121938.e0f59ee.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:34:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 501893 None MERGED Remove VXLAN type driver from OVN environment files 2020-02-13 06:37:51 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:34:53 UTC

Description Eran Kuris 2017-08-30 11:47:42 UTC
Description of problem:
In OVN yaml file /usr/share/openstack-tripleo-heat-templates/environments/neutron-ml2-ovn-ha.yaml
there is parameter the display incorect values.
OVN support only "Geneve" for Tunnel and tenant network. For provider network, we support vlan & flat  so we need to remove 'vxlan'

Version-Release number of selected component (if applicable):
OSP-12 with ovn 
rpm -qa |grep ovn
openvswitch-ovn-central-2.7.2-4.git20170719.el7fdp.x86_64
puppet-ovn-11.3.0-0.20170805080331.4425658.el7ost.noarch
rpm -qa |grep ovn
openvswitch-ovn-common-2.7.2-4.git20170719.el7fdp.x86_64
python-networking-ovn-3.0.0-0.20170807061656.2425483.el7ost.noarch
openvswitch-ovn-host-2.7.2-4.git20170719.el7fdp.x86_64
stack@undercloud-0 ~]$ rpm -qa |grep triple
puppet-tripleo-7.2.1-0.20170807233007.4600842.el7ost.noarch
openstack-tripleo-image-elements-7.0.0-0.20170725091025.f3f06c7.el7ost.noarch
openstack-tripleo-common-containers-7.4.1-0.20170807001945.8c46306.el7ost.noarch
openstack-tripleo-puppet-elements-7.0.0-0.20170803140906.4e7d35d.el7ost.noarch
openstack-tripleo-ui-7.2.1-0.20170805065336.ac9467f.el7ost.noarch
openstack-tripleo-common-7.4.1-0.20170807001945.8c46306.el7ost.noarch
python-tripleoclient-7.2.1-0.20170807222309.a731597.el7ost.noarch
openstack-tripleo-heat-templates-7.0.0-0.20170805163048.el7ost.noarch
openstack-tripleo-validations-7.2.1-0.20170807182119.1f60b6f.el7ost.noarch


How reproducible:
always 

Steps to Reproduce:
1. cat /usr/share/openstack-tripleo-heat-templates/environments/neutron-ml2-ovn-ha.yaml

2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Miguel Angel Ajo 2017-11-21 13:37:20 UTC
Wasn't this already fixed?

Comment 4 Miguel Angel Ajo 2017-11-21 13:38:44 UTC
Ok this was already fixed in U/S master (for OSP13)

Comment 7 Eran Kuris 2018-03-28 15:08:11 UTC
Fixed in  13   -p 2018-03-02.2
[stack@undercloud-0 ~]$ rpm -qa | grep openstack-tripleo-heat-templates
openstack-tripleo-heat-templates-8.0.0-0.20180227121938.e0f59ee.el7ost.noarch

/usr/share/openstack-tripleo-heat-templates/environments/services-docker/neutron-ovn-ha.yaml
NeutronTypeDrivers: 'geneve,vlan,flat'

Comment 9 errata-xmlrpc 2018-06-27 13:34:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.