Bug 1486840 - [modularity] Error: No such module: $name:$stream:$version
Summary: [modularity] Error: No such module: $name:$stream:$version
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libdnf
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Hatina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1478068
TreeView+ depends on / blocked
 
Reported: 2017-08-30 15:30 UTC by Martin Hatina
Modified: 2018-03-22 09:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-22 09:12:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Hatina 2017-08-30 15:30:41 UTC
Description of problem:
Dnf doesn't work with $name:$stream:$version. It doesn't find the specific version.

Version-Release number of selected component (if applicable):
dnf-2.6.5

How reproducible:
always

Steps to Reproduce:
1. dnf module info $name:$stream:$version


Actual results:
Error: No such module: $name:$stream:$version

Expected results:
Detailed info about $name:$stream:$version

Additional info:

Comment 1 Martin Hatina 2017-08-30 15:51:34 UTC
I think the problem is in libdnf. The version is stored in int (timestamp like this 20170616094812 doesn't fit into int).

Comment 2 Martin Hatina 2017-09-25 11:12:51 UTC
Fixed in https://github.com/rpm-software-management/dnf/tree/wip/modularity

Comment 3 Fedora End Of Life 2018-02-20 15:30:58 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.


Note You need to log in before you can comment on or make changes to this bug.