Bug 1486925 - Error on upgrading shim
Summary: Error on upgrading shim
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: shim-signed
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-30 19:27 UTC by Bastien Nocera
Modified: 2017-09-13 21:49 UTC (History)
3 users (show)

Fixed In Version: shim-13-0.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-13 21:49:24 UTC
Type: Bug


Attachments (Terms of Use)

Description Bastien Nocera 2017-08-30 19:27:21 UTC
Current shim version:
shim-0.8-10.x86_64

dnf is trying to update to:
shim-ia32-13-0.3
and:
shim-x64-13-0.3

And during the transaction test:
 Problem 11: both package shim-x64-13-0.3.x86_64 and shim-ia32-13-0.3.x86_64 obsolete shim < 13-0.3
  - cannot install the best update candidate for package shim-0.8-10.x86_64

Only one of those can obsolete "shim". I would make shim-ia32 depend on shim-86_64 instead.

Comment 1 Peter Jones 2017-08-31 13:42:53 UTC
trillian:~/tmp$ rpm -qp shim-ia32-13-0.4.x86_64.rpm --obsoletes
trillian:~/tmp$ rpm -qp shim-ia32-13-0.4.x86_64.rpm --provides
bundled(openssl) = 1.0.2j
shim-ia32 = 13-0.4
shim-ia32(x86-64) = 13-0.4
shim-signed-ia32 = 13-0.4
trillian:~/tmp$

Comment 2 Fedora Update System 2017-08-31 13:44:32 UTC
shim-signed-13-0.4 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-cad5ba1456

Comment 3 Adam Williamson 2017-09-13 21:49:24 UTC
13-0.4 was tagged into 27 directly, so closing this.


Note You need to log in before you can comment on or make changes to this bug.