Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1486938 - [DOCS] Metrics installation docs do not document nodeselector installer flags
Summary: [DOCS] Metrics installation docs do not document nodeselector installer flags
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: brice
QA Contact: Anping Li
Vikram Goyal
URL:
Whiteboard: 3.7-release-plan
: 1442264 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-30 20:46 UTC by Erik M Jacobs
Modified: 2018-12-19 21:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-18 02:19:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Erik M Jacobs 2017-08-30 20:46:42 UTC
openshift_metrics_hawkular_nodeselector={"region":"infra"}
openshift_metrics_cassandra_nodeselector={"region":"infra"}
openshift_metrics_heapster_nodeselector={"region":"infra"}

These flags are supported by the installer but are not documented in 3.5 or 3.6:

https://docs.openshift.com/container-platform/3.6/install_config/cluster_metrics.html

Comment 1 brice 2017-09-05 01:06:09 UTC
PR created for this BZ:

https://github.com/openshift/openshift-docs/pull/5161

Pretty much just added the parameters to the table.

Erik, is there any more context for the parameters? Not sure if it requires a little more efforts.

Comment 2 Erik M Jacobs 2017-09-13 14:47:56 UTC
A little extra context couldn't hurt (eg: a gentle reminder that the node selector will ensure which nodes the stuff runs on and that those labels need to exist).

However, we would want to stay consistent with the logging docs, as well.

Comment 3 brice 2017-10-11 00:26:02 UTC
Thanks, Erik. I've updated the variables with context on nodeselectors.

If there's anything more, let me know. I'll move this to review.

Comment 4 Erik M Jacobs 2017-10-11 13:01:12 UTC
I don't think there's anything more.

Comment 5 openshift-github-bot 2017-10-12 00:54:01 UTC
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/246aab1a8637413003bbc88a407d36130feb588a
Merge pull request #5161 from bfallonf/metricsenv_1486938

Bug 1486938 Added nodeselector to metrics docs

Comment 6 Vikram Goyal 2017-10-18 02:19:03 UTC
Docs published live here: 
https://docs.openshift.com/container-platform/3.6/install_config/cluster_metrics.html

Moving this bug to CLOSED-->CURRENTRELEASE.

Comment 7 Michael Burke 2018-12-19 21:38:30 UTC
*** Bug 1442264 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.