Bug 1487006 - Kernel fails to enumerating usb3 devices on EXYNOS boards
Summary: Kernel fails to enumerating usb3 devices on EXYNOS boards
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 26
Hardware: armhfp
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2017-08-31 04:06 UTC by Stewart Samuels
Modified: 2018-02-28 18:00 UTC (History)
26 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-02-28 18:00:01 UTC


Attachments (Terms of Use)
dmesg output. (44.01 KB, application/pdf)
2017-08-31 04:06 UTC, Stewart Samuels
no flags Details

Description Stewart Samuels 2017-08-31 04:06:14 UTC
Created attachment 1320363 [details]
dmesg output.

Description of problem:  F26 does not recognize either the onboard USB3 ports or the onboard Gigabit Ethernet on the Odroid XU4. 


Version-Release number of selected component (if applicable): F26


How reproducible: Always


Steps to Reproduce:
1.Boot the system
2.Perform "ifconfig -a" to verify that the device name for the onboard Ethernet is not generated to be configured.  Also, dmesg does not contain any information suggesting recognition of Ethernet hardware to configure.
3.Per the USB3 ports, plug in any USB3 device or hub to either of the USB3 ports.  Then check dmesg to verify that the devices are NOT recognized.

Actual results:  See Steps to Reproduce above.


Expected results:  See Steps to Reproduce above.


Additional info:

Comment 1 Peter Robinson 2017-09-19 09:11:02 UTC
Possible patch proposed upstream http://www.spinics.net/lists/arm-kernel/msg606525.html

Comment 2 Laura Abbott 2018-02-28 03:43:35 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.


Note You need to log in before you can comment on or make changes to this bug.