Bug 1487007 - incorrect syntax in /etc/init.d/cobblerd cause error shown in message log
Summary: incorrect syntax in /etc/init.d/cobblerd cause error shown in message log
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Installation
Version: 2.6
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Jan Dobes
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space28
TreeView+ depends on / blocked
 
Reported: 2017-08-31 04:09 UTC by BetaBoy
Modified: 2018-04-20 12:30 UTC (History)
0 users

Fixed In Version: cobbler20-2.0.11-71
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-20 12:30:53 UTC


Attachments (Terms of Use)

Description BetaBoy 2017-08-31 04:09:58 UTC
Description of problem:

Routine browsing through the message logs find these error lines:

Aug 31 10:54:49 server1 systemd: [/run/systemd/generator.late/cobblerd.service:11] Failed to add dependency on network,.service, ignoring: Invalid argument
Aug 31 10:54:49 server1 systemd: [/run/systemd/generator.late/cobblerd.service:12] Failed to add dependency on xinetd,.service, ignoring: Invalid argument

and "systemctl status cobblerd.service" also showing red lines about these error.

Further checking found that it is caused by /etc/init.d/cobblerd.
Here is the fix I've applied to clear this error:

# diff cobblerd.orig cobblerd
10c10
< # Required-Start: network, xinetd, httpd
---
> # Required-Start: network xinetd httpd

Could you help to fix this in the repo package?
Thanks

Version-Release number of selected component (if applicable):

The cobbler is install from spacewalk repo by dependency:
# rpm -q cobbler20
cobbler20-2.0.11-62.el7.noarch

It is a new spacewalk 2.6 installation (RPM/YUM method).

Comment 1 Jan Dobes 2017-10-27 13:26:08 UTC
In next Spacewalk 2.8 release is there going to be systemd service file but fixing init.d file anyway, cobbler.git(release20):

78f29a11af24338eee6a485c7e7c6bc08d023020

Comment 2 Jiří Dostál 2018-03-26 12:16:19 UTC
Moving ON_QA

Comment 3 Jiří Dostál 2018-04-20 12:30:53 UTC
Spacewalk 2.8 has been released.
https://github.com/spacewalkproject/spacewalk/wiki/ReleaseNotes28


Note You need to log in before you can comment on or make changes to this bug.