Bug 1487045 - Tempest test_update_router_admin_state failure on OVN setup
Summary: Tempest test_update_router_admin_state failure on OVN setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Numan Siddique
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-31 07:02 UTC by Eran Kuris
Modified: 2019-09-09 17:07 UTC (History)
9 users (show)

Fixed In Version: python-networking-ovn-4.0.0-0.20180220131809.329d6d8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:34:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1714176 None None None 2017-08-31 07:04:20 UTC
OpenStack gerrit 499552 None master: MERGED networking-ovn: Handle the admin_state_up flag in router update correctly (I435091de1cbdf5141903789b5d45c642498e518c) 2018-02-28 13:33:53 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:34:53 UTC

Description Eran Kuris 2017-08-31 07:02:45 UTC
Description of problem:
The following tempest test is failing on OVN environment:
tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_update_router_admin_state

The scenario of the test is creating a router that is connected to an external network and a private network.
Booting one instance that is connected to the private network and has a floating IP on the external network.

The test sets the router admin state to "DOWN":
Expected: ping to the VM floating IP will fail.
Actual Result: ping to the VM floating IP is working.


Traceback:
Traceback (most recent call last):
  File "tempest/common/utils/__init__.py", line 89, in wrapper
    return f(self, *func_args, **func_kwargs)
  File "tempest/scenario/test_network_basic_ops.py", line 527, in test_update_router_admin_state
    should_check_floating_ip_status=False)
  File "tempest/scenario/test_network_basic_ops.py", line 212, in check_public_network_connectivity
    self.servers, mtu=mtu)
  File "tempest/scenario/manager.py", line 609, in check_public_network_connectivity
    mtu=mtu)
  File "tempest/scenario/manager.py", line 592, in check_vm_connectivity
    msg=msg)
  File "/home/centos/tempest-upstream/lib/python2.7/site-packages/unittest2/case.py", line 702, in assertTrue
    raise self.failureException(msg)
AssertionError: False is not true : ip address 10.0.0.217 is reachable

Version-Release number of selected component (if applicable):
OSP-12 - HA - OVN
# rpm -qa |grep -i ovn
openvswitch-ovn-common-2.7.2-4.git20170719.el7fdp.x86_64
python-networking-ovn-3.0.0-0.20170807061656.2425483.el7ost.noarch
openvswitch-ovn-host-2.7.2-4.git20170719.el7fdp.x86_64
puppet-ovn-11.3.0-0.20170805080331.4425658.el7ost.noarch
openvswitch-ovn-central-2.7.2-4.git20170719.el7fdp.x86_64

How reproducible:
always

Steps to Reproduce:
1.Deploy OSP12 with OVN HA setup 
2.Run the following Tempest test: tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_update_router_admin_state

Expected: ping to the VM floating IP will fail.
Actual Result: ping to the VM floating IP is working.

Additional info:

Comment 2 Numan Siddique 2017-10-03 06:59:50 UTC
The commit [1] fixes this issue and the latest puddle has this fix.
This test should pass now.

[1] - https://github.com/openstack/networking-ovn/commit/b2de78357f4eccfba41abbbb9fb6d6b573caf8a8

Comment 3 Eran Kuris 2017-10-03 13:36:45 UTC
PLease add " fixed in version" field

Comment 10 errata-xmlrpc 2018-06-27 13:34:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.