Bug 1487110 - Role configuration of nodes doesn't close or save properly
Summary: Role configuration of nodes doesn't close or save properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-31 09:28 UTC by Dima
Modified: 2018-06-27 13:34 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-ui-8.3.1-0.20180303225336.57e3d96.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:34:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1747640 None None None 2018-02-06 10:38:54 UTC
OpenStack gerrit 541237 None master: MERGED tripleo-ui: Better Parameters fetching and updating state tracking (I34b40727e3feda71533d1c07eccf36221f2467eb) 2018-03-21 13:43:03 UTC
OpenStack gerrit 544000 None master: MERGED tripleo-ui: Convert Role detail dialog to redux-form (I302c24b4cb4e94230c213305a536fa9e6ad09296) 2018-03-21 13:42:56 UTC
OpenStack gerrit 544001 None master: MERGED tripleo-ui: Parameters cleanup (I74dd698e6adfbc23b57afc22b90e14a985fb843d) 2018-03-21 13:42:50 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:34:53 UTC

Description Dima 2017-08-31 09:28:14 UTC
Description of problem:
When attempting to edit role parameters, the windows will not close after saving changes (missing "save and close" button). Also, when switching tabs, changes will not save unless "save changes" is pressed.  

Version-Release number of selected component (if applicable):


How reproducible:
When editing role parameters

Steps to Reproduce:
1. Log in to director ui
2. From  Deployment plan page edit role configuration by clicking on a "pen" icon on the right top corner of the role
3. Change one of the parameters
4. Switch to a different tab and back
5. Click on "save changes"

Actual results:
The change that was made before switching to a different tab was not saved and clicking on "save changes" is needed before switching to another tab which is counter-intuitive. After clicking on "save changes" the window will not close.

Expected results:
Configuration was successfully saved. After clicking "save changes" deployment plan page is shown. Changes on one tab should be saved when switching to another without the need to click "save changes"

Comment 4 Jiri Tomasek 2018-02-06 10:40:22 UTC
This bug is partially fixed by https://review.openstack.org/#/c/541237/ but in general it is going to be fixed once role detail form gets converted to using redux-form

Comment 6 Jiri Tomasek 2018-02-14 08:36:15 UTC
I have added references to 2 additional gerrit patches which convert RoleDetail dialog to redux-form. These completely fix all the issues reported here. These patches are supposed to land in Queens RC1, so in time for OSP13

Comment 9 Udi 2018-04-04 11:18:25 UTC
Verified: openstack-tripleo-ui-8.3.1-2.el7ost.noarch

Comment 11 errata-xmlrpc 2018-06-27 13:34:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.