Bug 1487182 - When exporting a disk to Glance, the size shown is its "Virtual Size" but the title is "Actual Size".
Summary: When exporting a disk to Glance, the size shown is its "Virtual Size" but the...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.2.0
: ---
Assignee: shani
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-31 11:52 UTC by shani
Modified: 2017-12-20 11:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:05:06 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
Column's title is "Actual Size", but the data is the disk's virtual size. (28.72 KB, image/png)
2017-08-31 11:52 UTC, shani
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 81350 0 master MERGED webadmin: Change "Actual Size" column's title 2017-09-25 11:08:08 UTC

Description shani 2017-08-31 11:52:28 UTC
Created attachment 1320559 [details]
Column's title is "Actual Size", but the data is the disk's virtual size.

Description of problem:
When exporting a disk image from storage > disks, the size shown at the disk's summery refers to the disk's "Virtual Size", although the column's title is "Actual Size". 

Version-Release number of selected component (if applicable):
4.2.0

How reproducible:
100%

Steps to Reproduce:
1. Export a disk from storage > disks
2. Look at the "Actual Size" column on disk's summery details. 

Actual results:
|Actual Size|
-------------
|10 GB      |

Expected results:
|Virtual Size|
--------------
|10 GB       |

Additional info:
-

Comment 1 Raz Tamir 2017-10-15 13:46:44 UTC
Verified on ovirt-engine-4.2.0-0.0.master.20171013142622.git15e767c.el7.centos

Comment 2 Sandro Bonazzola 2017-12-20 11:05:06 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.