Bug 1487312 - FE NPE when selecting a snapshot row
Summary: FE NPE when selecting a snapshot row
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Alexander Wels
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-31 15:31 UTC by jniederm
Modified: 2017-12-20 11:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:36:09 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
ui.log (4.07 KB, text/plain)
2017-08-31 15:31 UTC, jniederm
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 81537 0 master POST webadmin: Overlay presenter rework 2017-09-06 15:49:58 UTC

Description jniederm 2017-08-31 15:31:03 UTC
Created attachment 1320645 [details]
ui.log

Description of problem:
Vojtobox pops up (FE error box) when a snapshot is selected right after viewing Task.

Version-Release number of selected component (if applicable):
current master, commit f2d4194e5c

How reproducible:
100%

Steps to Reproduce:
1. Create a VM
2. Refresh webadmin page
3. Show VM detail
4. Select Snapshots tab
5. Click Tasks icon in upper right corner
6. Click Tasks icon again to close Tasks view
7. Select arbitrary row in snapshot list, e.g. "Active VM"

Actual results:
Vojtobox pops up, see attached ui.log

Expected results:
snapshot row selected

Additional info:

Comment 1 Greg Sheremeta 2017-08-31 22:58:30 UTC
It ends up that VmSnapshotListModel's entityModel.entity becomes null when Tasks is opened and closed. VmSnapshotListViewItem line 202, listModel.getEntity() fails.

Alexander should be way more familiar with this code.

Comment 2 Petr Matyáš 2017-10-09 14:30:29 UTC
Verified on ovirt-engine-4.2.0-0.0.master.20171009063348.gitf2b70a1.el7.centos.noarch

Comment 3 Sandro Bonazzola 2017-12-20 11:36:09 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.