Bug 1487399 - USB OTG port not recognised on the Beagle Bone Black
Summary: USB OTG port not recognised on the Beagle Bone Black
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: armv7hl
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2017-08-31 18:53 UTC by Medic Momcilo
Modified: 2018-04-27 04:09 UTC (History)
23 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-22 18:42:25 UTC


Attachments (Terms of Use)
Kernel log showing the error. (33.91 KB, text/plain)
2017-08-31 18:53 UTC, Medic Momcilo
no flags Details
Latest kernel log showing the error. (33.63 KB, text/plain)
2017-08-31 20:07 UTC, Medic Momcilo
no flags Details

Description Medic Momcilo 2017-08-31 18:53:39 UTC
Created attachment 1320697 [details]
Kernel log showing the error.

Description of problem:
Beagle Bone Black has two USB ports, one Host (Type A), and one Peripheral (Mini-B). Host USB is detected properly and works just fine. Peripheral one is not configured properly as seen in dmesg.

Version-Release number of selected component (if applicable):
4.11.8-300.fc26.armv7hl

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora 26 on Beagle Bone Black
2. Check dmesg

Actual results:
Errors displayed.

Expected results:
No errors displayed.

Additional info:
I discovered this as I was failing to configure network adapter on Peripheral USB via configfs. I am attaching dmesg from freshly booted Beagle Bone Black (error on line 260).
I would be happy to provide more information if required.

Comment 1 Medic Momcilo 2017-08-31 20:06:08 UTC
Updated to kernel-4.12.8-300.fc26.armv7hl.
Unfortunately, same results - attaching new dmesg.

Comment 2 Medic Momcilo 2017-08-31 20:07 UTC
Created attachment 1320706 [details]
Latest kernel log showing the error.

Comment 3 peter.enderborg 2017-09-25 11:39:11 UTC
This is the error displayed. 
[   17.476859] musb-dsps: probe of 47401400.usb failed with error -16

-16 I think is EBUSY. So it might be some pins changed.

Comment 4 peter.enderborg 2017-09-26 06:25:58 UTC
[   16.634624] [<c063ac38>] (dump_stack) from [<c03ab324>] (__setup_irq+0x580/0x5c8)
[   16.645575] [<c03ab324>] (__setup_irq) from [<c03ab4dc>] (request_threaded_irq+0xbc/0x174)
[   16.657295] [<c03ab4dc>] (request_threaded_irq) from [<c03ad854>] (devm_request_threaded_irq+0x78/0xb8)
[   16.670249] [<c03ad854>] (devm_request_threaded_irq) from [<bf36f0d0>] (dsps_probe+0x12c/0x404 [musb_dsps])
[   16.683606] [<bf36f0d0>] (dsps_probe [musb_dsps]) from [<c0790d2c>] (platform_drv_probe+0x58/0xa4)

Something with irq pin config.

Comment 5 Laura Abbott 2018-02-28 03:37:35 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.

Comment 6 Medic Momcilo 2018-03-02 19:01:32 UTC
This is still an issue with kernel "kernel-4.15.6-300.fc27.armv7hl".
Updated bug to reflect Fedora 27 release.

Comment 7 Peter Robinson 2018-04-12 16:32:07 UTC
The problem has been identified, if the tps65217-charger driver is enabled it clobbers the USB port for some reason. This is a known issue and the BBone community currently just disable that driver to work around the issue. Will be fixed in the 4.16 rebase

Comment 8 Fedora Update System 2018-04-20 13:30:58 UTC
kernel-4.16.3-300.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7b851cd56d

Comment 9 Fedora Update System 2018-04-21 18:37:34 UTC
kernel-4.16.3-300.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7b851cd56d

Comment 10 Medic Momcilo 2018-04-22 18:42:25 UTC
Hey Peter,

Thank you for taking time to check this, it is highly appreciated.
I can confirm that this resolves the reported USB OTG issue.

This ticket is now set to resolved.

Kind regards,
Momo.

Comment 11 Fedora Update System 2018-04-27 04:09:41 UTC
kernel-4.16.3-300.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.